cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
HelloWorld
Frequent Visitor

BUG Empty Person field is not updating upon record changes

I have a gallery and a form (view mode) on the same screen.

The form will display detail information such as department, people (type of Person in SP), description, etc. associated to the selected i made in the gallery.

 

What I've noticed is the Person field does not honor empty value. Here is an example.

Assuming I have the following data

Gallery item 1, Form person value is John Dole

Gallery item 2, Form person value is empty

Gallery item 3  Form person value is Mary Jane

 

When I select item 1 in the gallery, It will display John Dole in the form, when I select item 2, the form will display John Dole (instead of emtpy). When i select item 3, the form will display Mary Jane. If i select item 2 next, it will display Mary Jane instead of empty.

 

Please fix it.

3 REPLIES 3
Jeff_Thorpe
Super User
Super User

I just tried this and it works fine. I have one screen that has a gallery and a display. I am using a list with a Person/Group field on it and some of the items have a user value and some don't. When I select an item that has a person then that person gets displayed in the form. If the next item I select doesn't have a person listed then the form doesn't display a value for the person field. I thought I might be able to find a work around to your issue but I can't reproduce it.



--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.
v-monli-msft
Community Support
Community Support

Hi @HelloWorld,

 

I also cannot reproduce your issue. My Display Form Items property is:

Gallery1.Selected

 

And when I select one item that does not have any value in People and Group column, it would show empty in Display Form:

Capture.PNG

 

What is the formula of the Item property of your display form?

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks guys for checking. I tried to recreate the issue again but couldn't. So what I did was replace the form with a new one and the issue seem to go away.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,218)