cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper IV
Helper IV

Bad Gateway Error with Flow

Hi Power Apps community, 

 

I have created a flow to display information in PowerApps. The flow is as follows:

 

FlowGetData1.pngFlowGetData2.png

 

I have a TextInput in PowerApps were users can enter an id. That Id is the Get Items ID. My logic is when a user enter an id, for flow to go and get the item from SharePoint and Display it to PowerApps. I want the flow to work as a search function. I don't see any errors in my flow, but when I run the flow it gives me a "bad gateweay  code 502". My Sharepoint list contains more than 4000 records so this is an alternative for the search delegation problem in the Gallery.

 

Can someone help me?

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Bad Gateway Error with Flow

Hi @JB0007 ,

Where do you call the flow from your canvas app?

Have you checked the Run History of your flow? Which action faces the "Bad Gateway 502" error? Is it the "Get item" action?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The flow's configuration as below:

1.JPG

The app's configuration as below:

2.JPG

 

3.JPG

The flow runs successfully as below:

4.JPG

On your side, please check the "Run History" of your flow, then check which action faces the "Bad Gateway 502" error. Also please consider take a try converting the received List Item ID value (passed from your canvas app) into a integer value using int function in your flow as below:

5.JPG

 

In addition, you could consider fire the flow manually within your flow itself, then pass a specific ID value, then check if your flow could run successfully without any error. If the issue still exists, I think this issue is related to your flow itself rather than your canvas app. You could consider re-create a new flow or re-create a new connection to the action (which faces this "Bad Gateway 502" error) in your flow, then remove the flow connection from your app, then re-create a new connection to your modified flow, then check if the issue is fixed.

 

Also please consider remove the flow connection from your canvas app, then save your canvas app, then re-load your canvas app, add a new connection to your flow from your app, then try the flow action again, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper IV
Helper IV

Re: Bad Gateway Error with Flow

Hi @v-xida-msft , thanks for the reply.

 

I have tested your flow but unfortunately it returns blank items back. The thing is the Get Item Id is only applicable for the absolute ID of teh SharePoint List. So if I enter an Id that I have created e.x Entry_Id = 4578, It would not return the records that correspond to that specific Entry_Id.

 

Thanks again for the help.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,371)