cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Runner55552
Helper IV
Helper IV

Bad data source error in PowerApp

I have two PowerApps (one is a SharePoint list integrated app, one is a standalone canvas app). Both submit to the same SharePoint list, which affected Powerapp users have edit access to.  Although I can submit forms using either app with no errors (I am the author), and I have shared the apps with users, and they have edit permissions on the SharePoint list in question, the users are able to run the app, and fill out information, but when the tap Submit (to submit the form), they get a bad data source error, and the form will not submit. The shared users are in my organization, have the proper Microsoft credentials, and I have shared the app with them. Any insight would be appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions

It turns out that when I copied/cloned the PowerApp and deployed it on a different SharePoint list, even though I changed all the references, it seems that some data cards retained the old information in their memory, and were causing the submission error. I deleted the data cards in question, and re-inserted them by "adding a field."  That removed the errors.

View solution in original post

4 REPLIES 4
v-monli-msft
Community Support
Community Support

Hi @Runner55552 ,

 

For custom form in SharePoint, please try to change back to the default standard SharePoint form, and let the users try to add new items again. Just to confirm if the issue is related to PowerApps.

 

For the standalone app, please let the users to edit the SharePoint list items directly from SharePoint site and check if the issue is related to the permission.

 

Regards,

Mona

 

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

It turns out that when I copied/cloned the PowerApp and deployed it on a different SharePoint list, even though I changed all the references, it seems that some data cards retained the old information in their memory, and were causing the submission error. I deleted the data cards in question, and re-inserted them by "adding a field."  That removed the errors.

View solution in original post

Hi @Runner55552 ,

 

Glad to know that your issue is solved.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-monli-msft 

Help Please


I have a task management application, in which user store information of the task assigned to them. The Application uses SQL Server as its data source. But, there are some errors in ever table formula, that Bad Data Source Error, inner exception.
error.jpg

Although there are errors in application but it's running on Desktop and working fine, but when the user opens the application on mobile device it shows Bad DataSource errors in the whole screen.  
MicrosoftTeams-image.jpg

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (1,203)