cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Bizarre difference between web browser and mobile behaviour

I have an app with 3 screens: a master data screen (VehicleScreen) , a detailed data screen (DetailScreen), and a data form(scrnInspect).  When creating new records on scrnInspect I get wildly different results in the web browser and the mobile version of the app depending on the code.  I have ensured I am using the correct published version, etc.

 

Code snippet 1 from the onSelect Event of the check on scrnInspect:

SubmitForm(edfrmInspection);Navigate(DetailScreen,ScreenTransition.None)

 

Mobile Behaviour: Record writes correctly, App Navigates to DetailScreen

Broswer Behaviour: Record writes correctly, DetailScreen flashes brielfy, then scrnInspect reappears

 

Conde snippet 2 from the onSelect Event of the check on scrnInspect:

SubmitForm(edfrmInspection);ResetForm(edfrmInspection);Navigate(DetailScreen,ScreenTransition.None)

 

Mobile Behaviour: Record writes correctly, App navigates all the way back to VehicleScreen

Browser behaviour: Record writes correctly, App navigates back to DetailScreen as expected

 

Help!

 

 

 

 

 

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,450)