cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
patty789
Helper V
Helper V

Blank Gallery not showing up

Hi,

 

I am using a blank gallery and i am putting some combo box and text input and for whatever reason the gallery does not show the controls when i hit play. I am using a collection.  I been trying to figure it why yet no solution yet. Any help will be appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @patty789 ,

Does your Gallery connect to a empty collection table?

Do you want to display the ComboBox controls within your Gallery, even though, the Gallery is empty?

 

Actually, it is an normal behavior in PowerApps. When you are in Edit mode, if you add some controls into a empty Gallery, you could see these inserted controls. But when you click "Preview" button in your PowerApps Studio, the inserted controls would not show up, due to the Gallery is empty.

If you want the insert controls to be displayed within the empty Gallery when you preview this app, I afraid that there is no way to achieve your needs in PowerApps currently.

 

So please make sure the Gallery contains one record (one Blank record record is OK) at least within your app, to display these inserted controls.

 

On your side, you could consider initialize your collection table as below:

ClearCollect(TempCollection, {Column1: Blank(), Column2: Blank()});

then the collection table would contain one blank record. Then set the Items property of the Gallery to this collection table.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-xida-msft
Community Support
Community Support

Hi @patty789 ,

Does your Gallery connect to a empty collection table?

Do you want to display the ComboBox controls within your Gallery, even though, the Gallery is empty?

 

Actually, it is an normal behavior in PowerApps. When you are in Edit mode, if you add some controls into a empty Gallery, you could see these inserted controls. But when you click "Preview" button in your PowerApps Studio, the inserted controls would not show up, due to the Gallery is empty.

If you want the insert controls to be displayed within the empty Gallery when you preview this app, I afraid that there is no way to achieve your needs in PowerApps currently.

 

So please make sure the Gallery contains one record (one Blank record record is OK) at least within your app, to display these inserted controls.

 

On your side, you could consider initialize your collection table as below:

ClearCollect(TempCollection, {Column1: Blank(), Column2: Blank()});

then the collection table would contain one blank record. Then set the Items property of the Gallery to this collection table.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,827)