cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SilentUK
Advocate II
Advocate II

Book a room Template - No rooms avaliable

Hi All,

 

I am using the room bookings template and having a problem.  When choosing the option "Book for an existing meeting", it shows the message "There are no rooms available".  I have checked all of the rooms and all 4 are free on that time.  What makes this really strange is that if I go in and edit the meeting time, it will then bring a list of all the rooms.  Stranger still, I can "Edit" the meeting time to the exact same time (e.g 1:00 - 1:30, shows no rooms, update the time to 1:00 - 1:30 and the rooms pull through).

 

Anyone have any ideas what can cause this?

I created a new version of the app from scratch to make sure it was nothing I had done inadvertently, but even in the new app template I get this same error.

 

Screenshots below:

Before "Update":

before.PNG

After "update" (Note time and date is identical):After.PNG

 

Any ideas what can cause this?

1 ACCEPTED SOLUTION

Accepted Solutions
v-siky-msft
Community Support
Community Support

Hi @SilentUK ,

 

Try to delete the If condition in OnVisible of RoomSelectScreen. Please check the following screenshot, delete the code under the red line, then check if your issue is fixed.

Snipaste_2019-11-19_16-39-41.png

Best regards,

Sik

View solution in original post

4 REPLIES 4
v-siky-msft
Community Support
Community Support

Hi @SilentUK ,

 

Try to delete the If condition in OnVisible of RoomSelectScreen. Please check the following screenshot, delete the code under the red line, then check if your issue is fixed.

Snipaste_2019-11-19_16-39-41.png

Best regards,

Sik

This resolved the issue,  thank you very much.  Strangely, now i removed the code, i added it back in to test if it broke again and all still works with the code back in.  I had recently updated the names of my rooms in 365 so I wonder if it was struggling to pull through the details while it updated on the backend.  Either way... all resolved now.  Thanks @v-siky-msft !

Hi,

 

I got the same issue. Tried deleting the code as you mentioned. But nothing changed. Did you do anything other than deleting the code snippet in "if" condition? Keen to get this resolved.

Any help is much appreciated.

 

Thanks in advance,

 

No, Strangely, I just left it over the weekend, came back on the Monday morning and it was "magically" working.  No idea what cause it to start working as nothing would have changed.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,696)