cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
slan2018
Helper II
Helper II

Brand New at Power Apps and I'm getting the "Data Source May Be Invalid" Error and have other questions.. Please help!

I am brand new at this and need some help. I am trying to create a form based on a Sharepoint List. I think I've connected everything but the submission piece is not working. 

 

My Sharepoint list has roughly 15 items that the user will need to fill out and submit. I would like the submission to go back to the data source to be stored. 

 

As you can see I have a few questions on the below. image.png

 

image.png

 

At this point when I go into Preview and key in some data and then press the checkmark, it gives me the data source error. I'm not sure how to proceed. Any thoughts? I feel like i'm missing some crucial step in connecting the data and then having it save back to Sharepoint. My only data source is my SP page.

 

image.png

image.png

1 ACCEPTED SOLUTION

Accepted Solutions

Hi @slan2018 

 

Try creating a new App and connect to your sharepoint list

 

Use the Form control (edit form) - connect to sharepoint list and make sure form mode is set to New

 

and then add a button and OnSelect of button do SubmitForm(formname)

 

and test to see first if data is posting to your data source

View solution in original post

8 REPLIES 8
RezaDorrani
Dual Super User II
Dual Super User II

Hi @slan2018 

 

the browse screen enables you to select items (browse screen is similar to the sharepoint list view)

 

how did you create this App? from blank or did you go to SharePoint and created the app from your data source

 

did u make any changes to the list structure after creating the App?

Hi @RezaDorrani 

I went into my SP list and created the app from there. I have not changed any of the list structure since I initially created it. 

Hi @slan2018 

save and publish the App

then close the App and again try and edit the app and see if app functions

 

 

Hi @RezaDorrani , 

I did as you suggested, saved then published the app, closed and reopened and unfortunately i'm getting the same message. Is there anywhere else you can think of I should look at as far as how it's set up?

 

image.png

Hi @slan2018 

 

Try creating a new App and connect to your sharepoint list

 

Use the Form control (edit form) - connect to sharepoint list and make sure form mode is set to New

 

and then add a button and OnSelect of button do SubmitForm(formname)

 

and test to see first if data is posting to your data source

View solution in original post

v-xida-msft
Community Support
Community Support

Hi @slan2018 ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Based on the error that you mentioned, I think there is something wrong with the SP List connection in your app. Please consider remove the SP List connection within your app, then re-create a new connection to your SP List data source, try your app again, check if the issue is fixed.

 

In addition, please also consider re-generate a new app based on your SP List data source, then try your app again, check if the issue is solved.

More details about generating an app based on SP List data source, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/app-from-sharepoint

 

If the issue still exists, please consider submit your form data using Patch function instead of SubmitForm function. The standard formula format of Patch function as below:

Patch(
         'YourSPList',
         Defaults('YourSPList'),
         {
            Title: DataCardValue_Title.Text,
             'Sales Rep Name': DataCardValue_SalesRepName.Text,
            'Date Proposal Request Submitted': DatePicker1.SelectedDate,
             'Amount of Setup Fee': DataCardValue_AmountOfSetupFee.Text,
             ...
... } )

More details about Patch function, please check the following article:

Patch function

 

In addition, if you want to open a specific form via clicking a URL, please check if my response within the following thread would help in your scenario:

https://powerusers.microsoft.com/t5/Creating-Apps/Connecting-lists-and-having-all-information-in-one...

https://powerusers.microsoft.com/t5/General-Discussion/Editing-a-record-from-a-flow-powerapp/m-p/265...

 

Please take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
slan2018
Helper II
Helper II

Thank you @RezaDorrani !

@slan2018 

 

your welcome

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (81,608)