cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mavako
Frequent Visitor

BrowseGallery filtered by TextSearchBox

Hello,

I have an app - searchbox and browsegallery:

1.jpg

The source are columns "Part no after" and "Part no before" in table "TDD":

2.jpg

 

I would like to filter the Gallery by text in TextSearchBox. If the TextSearchBox is empty, all items vissible is OK, but if I write something to TextSearchBox there is nothing in Gallery. In this example I wrote "CC" which should view CC005, CC006, CC007 etc....but nothing viewed. 

3.jpg

this error

4.jpg

When I had source in GoosleSheet before in another App this fomrula was working. But now I have source in Excel Online (Business) and doesn't work.

 

Can somebody help me, please?

1 ACCEPTED SOLUTION

Accepted Solutions
timl
Super User
Super User

Hi @mavako 

I think you're right - this appears to be a problem with the Excel online business connector.

I can re-create the problem and the cause of this is the space in the column name. The search function works ok for me with columns that don't include a space.

Would it be easy for you to rename the column header so that it's "PartNoAfter" instead of "Part no after"?

View solution in original post

7 REPLIES 7
zmansuri
Super User
Super User

Search([@TDD],TextSearhBoox1.Text,ColumName1,ColumName2)

mavako
Frequent Visitor

I have it but doesn't work

Search([@TDD];TextSearchBox1.Text; "Part no after";"Part no before")

timl
Super User
Super User

Hi @mavako 

The Search function with the Excel Online Business connector supports only a single column.

The following workaround should hopefully work for you.

 

With({tdd1:Search([@TDD]; TextSearchBox1.Text; "Part no after")};
     Search(tdd1; TextSearchBox1.Text; "Part no before"))
)

 

mavako
Frequent Visitor

If I try to search only one column it doesn't work too

Search([@TDD]; TextSearchBox1.Text; "Part no after")

6.jpg

@timl doesn't work, the error is elsewhere probably

 

mavako
Frequent Visitor

I tried to create new Gallery in previous app with source Google Sheet the same way and works fine, so I think the issue is because of the source Excel online (business).

May be?

timl
Super User
Super User

Hi @mavako 

I think you're right - this appears to be a problem with the Excel online business connector.

I can re-create the problem and the cause of this is the space in the column name. The search function works ok for me with columns that don't include a space.

Would it be easy for you to rename the column header so that it's "PartNoAfter" instead of "Part no after"?

timl
Super User
Super User

Hi @mavako 

Could you try the following to see if this works for you?

With({tdd1:Search(RenameColumns([@TDD];"Part no after";"PartNoAfter";
                                "Part no before";"PartNoBefore"); 
                  TextSearchBox1.Text; "PartNoAfter")};
     Search(tdd1; TextSearchBox1.Text; "PartNoBefore"))
)

In the meantime, I've posted this issue in the ideas forum and you can vote for it to be fixed here:

https://powerusers.microsoft.com/t5/Power-Apps-Ideas/Bug-Excel-online-business-connector-fails-to-se...

 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Users online (1,230)