cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Browser stops working by clicking on the screen

Hi,

 

I duplicated a screen with a form and did a little changes.

Today after opening the App to edit that when I click each the screens (original and duplicated), all opened PowerApps tabs stops working and after a while it shows:

 
 
6 REPLIES 6
Highlighted
Community Support
Community Support

Re: Browser stops working by clicking on the screen

Hi @farsami1 ,

Could you show me the error message?

I couldn't see anything about error message in your issue.

I've made a similar test and not met the same problem like your description.

However, when I click the duplicated screen, it will stop working for a few seconds. Then, it will work as normal.

So maybe loading  duplicated screen really need some time.

I suggest you update your browser to the latest version, clean the brower's cache and try again.

What's more, please make sure that you are in a good condition of network , which will effect the app's performance too.

If the problem still exists, do you use large data of data source? Do you use many controls?

In this situation, you need to modify your app to improve your app's performance.

Here are some tips about it for your reference:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/performance-tips

 

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Frequent Visitor

Re: Browser stops working by clicking on the screen

Hi Phoebe,

 

Thanks for your prompt reply.

There's not any error message the page gets unresponsive.

The form have about 20 labels and controls, and the list is temporary with ~20 records.

to be sure I waited for the form to be opened over the night, nothing.

Now I am working with more complicated one and that's fine.

Also I tried that on Edge and Chrome and the result is the same.

The bigger problem is I tried the previous versions even before duplicating the screen and the result is the same. IT seems I lost all I've done.

Another thing is I can run the App but I cannot edit or view that.

Thank you again,

Faramarz

It seems to be a Bug of PowerApps.Annotation 2019-11-20 082310.pngAnnotation 2019-11-20 081421.png

 

Highlighted
Advocate V
Advocate V

Re: Browser stops working by clicking on the screen

I am experiencing exactly the same issue. I made a "minor" change to one screen a few days ago (Monday), namely setting the value of a Tooltip for a button. That was literally was the only changed I made to the app, a minor bug fix if you like. I did not experience the slighest performance-type issues in making that miniscule change to that one screen in the app. It is not all that complex of an app, consisting of a total of 8 screens, 12 SharePoint List Data Souces and 1 Flow (which isn't really used).

 

Having made that minor change to the app, I saved it and immediately published. Users have no problem whatsoever navigating to that specific screen now, which in turn renders the information expected. i.e. there are absolutely no performance issues in Runtime mode.

 

The issue I am experiecing now is that I cannot in PowerApps Studio in design mode navigate to that specific screen anymore, continuously get the same message per this thread, i.e. Page Unresponsive. Every other PowerApps tab "in my web brower-Chrom" that was open equally becomes completely unresponsive.

 

I am unable to even attempt to copy that screen in the left treeview menu. Once again the app immediate becomes unresponsive along with all the other PowerApps web browser tabs open.

 

I tried launching the Monitor under the Advanced Tools on the menu. That does open a new browser tab with displaying the typical content one would expect. However, again as soon as I in any way try to interact wigh that screen n the PowerApps Design Studio, even the Monitor tab in web browser session equally becomes unresponsive (no matter how long I wait)

 

I have attempted to try resolve the issue with every other possible avenues I could think of, including:

  • Restoring the previous of the app - no difference
  • Restoring a much older version of the app, each version tested corrosponding the the following PowerApps Release Numbers:
    • 3.19111.33
    • 3.19111.28
    • 3.19062.20
  • For all the steps detailed thus far, I was trying to attempt to resolve the issue in a Crome Browser session/tab running on an Apple MacBook
  • I then tried pretty much the exact same steps on a Windows 10 laptop (which I haven't used for some time):
    • I once again experienced the exactly the same issue irrespective of whether I tried those steps in both Chrome and Edge web browsers sessions. Equally all the other PowerApps tabs open in either Chrome or Edge instantly became unresponsive again.
  • Thereafter I exported the entired the entire app (an older version), and subsequently imported it again into the same Office 365 tenant, specificing a different app name but nothing else. That too made no difference. It only that single screen where I made the smallest possible change to the app I could really have made, and despite everything I have tested as detailed above, I am still experiencing the same issue and ONLY on that once screen I made that minor change.

I have spent the entire day trying to resolve this and got nowhere.

Highlighted
Frequent Visitor

Re: Browser stops working by clicking on the screen

That's too frustrating.

Yet, I am looking for a solution. But it seems that I have to start from scratch.

The bigger problem is I don't know how that happened to prevent that happening again.

Highlighted
Anonymous
Not applicable

Re: Browser stops working by clicking on the screen

I have the same issue. Any advice would be welcome.

Highlighted
Frequent Visitor

Re: Browser stops working by clicking on the screen

hi,

I could not solve the problem by myself.

I contacted Microsoft Support and after passing several tiers, they solved the problem.

They said it is a problem of one of the versions of PowerApps. 

I hope it helps.

Helpful resources

Announcements
Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (3,725)