cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Bug - Button controls on Android devices getting stuck with the pressed fill colour

I have noticed that the button controls on my main screen work fine until I navigate to my second screen which has Text Input boxes and I enter text into one of them. After doing that the buttons start playing up both on the screen with the text inputs and back on my main screen which has none. The buttons will press and carry out their OnSelect action however they get stuck displaying the button pressed colour so it looks like you are continuously pressing the button. You have to tap them again quickly to get the colour to change back to the normal fill colour. I have to shut down and re-open PowerApps to get it to stop. But as soon as I use a text box it starts again.

 

This issue has already been reported in other posts several times on this forum over the past few weeks but no response from Microsoft yet as far as I can see. @DerekPapworth 

 

A bug like this is a show stopper for my PowerApps clients. If this is not fixed quickly PowerApps will have to be dropped in favour of a more traditional and reliable approach to building apps for mobile devices.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Microsoft
Microsoft

Hi,

 

Thanks for your post of this. This is a known issue and we are presently working on this. You can always create a case on this too if you want to get updates on the bug or find out when it will be fixed. I'll include a link on creating a case if you ever want to go down that path.

 

If you would like to create a ticket with Microsoft Customer Support here is a link on how to do so: https://docs.microsoft.com/en-us/power-platform/admin/get-help-support

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Highlighted
Microsoft
Microsoft

Hi,

 

Thanks for your post of this. This is a known issue and we are presently working on this. You can always create a case on this too if you want to get updates on the bug or find out when it will be fixed. I'll include a link on creating a case if you ever want to go down that path.

 

If you would like to create a ticket with Microsoft Customer Support here is a link on how to do so: https://docs.microsoft.com/en-us/power-platform/admin/get-help-support

 

Regards,

 

Alex

 

-------

 

Community Support Team _ Alex Rezac
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted

I have also noticed this issues arise in the last few weeks, and may be a show-stopper for deploying my App to the Users...

 

But my concern is - How is the response "We've raised a ticket" been marked as a Solution?

There is currently no solution, so please don't mark a forum post as Solved!

 

James.

Highlighted
Frequent Visitor

Has anyone solved this problem?
We are experiencing the same issue, hence delaying us to deploy our app.

 

Highlighted

Microsoft have indicated that this problem is caused by Google's software and that there is nothing Microsoft can do about it. Something to do with Google Chrome and Android System webview. So looks like we will have to wait for Google to fix it. My organisation has already moved away from using Power Apps for most of our planned mobile phone based applications due to this and several other problems that have existed for years but have not been fixed. At least using more conventional programming methods to create applications we can fix most problems like this ourselves.

Highlighted

Hi @Fabprefab, we have the same problem and what we did was to set pressed button properties (fill, colour and border) the same as the colour properties (PressedColour=Self.Colour, PressedFill=Self.Fill and PressedBorderColour=Self.BorderColour), so although the problem still remains, it has not an impact on users. Users still see a change on buttons when they pressed them as they change from enable status to disable status for a while.

I hope this can help

 

Regards

 

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (7,710)