cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KLatch
Resolver I
Resolver I

Bug: Components and Fluid Grids

So I believe I've found a bug regarding the interaction of components and fluid grids. Basically, when I add a component to the page which contains a fluid grid control, if the Y value of the component is less than the Y value of the fluid grid, it causes problems with the spacing and location of items in the fluid grid.

 

In all of the cases in the screenshots below the only changes made are to the presence/absence of a component and to the Y variable of the component.

 

Case 1 - I have a brand new app, with an empty scrollable screen with 3 cards, with exciting colourful borders so the future changes are obvious. The fluid grid has a single column and behaves as expected with each card stacking on the other and no spaces between them. There is no component here.

Image 1 - No component.png
Case 2 - Same as above but I've added a simple component, it's just a label with no inputs or outputs. The component Y=0. Initially there is no observable change but after saving the app and reloading you can see the result is large gaps between the cards where there were none before. Just to reiterate, there was no change to the columns setting of the fluid grid, the height settings of the cards, or any other property for that matter. The only difference is the addition of the component in the top left.Image 2 - Component Y eq 0.png

 

Case 3 - the only change made between case 2 and 3 is that the Y property of the component changes to one greater than that of the Y property of the fluid grid. After making this change and saving and reloading the app, the gaps disappear and everything is back to normal.Image 3 - Component Y gt Fluid grid.png

 

I'm curious to see whether this scenario can be recreated by anyone else and if anyone has any suggested workarounds (other than just not using components). My intention was to use components to handle page headers and navigation, both of which would require the component to have a Y value of 0, thus making scrollable sections/fluid grids useless.

 

It is also distinctly possible I have overlooked something entirely and this isn't a bug. If so, if someone could enlighten me that would also be appreciated.

 

Thanks in advance.

 

2 REPLIES 2
yfw
Power Apps
Power Apps

We have investigated the issue and a fix is on the way. Thanks for reporting the issue.

yfw
Power Apps
Power Apps

The fix has been delpoyed. Please check again and let us know any issue. Thanks!

Yifei

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (78,457)