cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Bug -- Editing a form with "Attachments" and then saving causes duplicates

I have created an app with a form connected to a CDS entity.  The CDS entity is set to "Allow attachments".  When I add an image to the attachment field (which comes from the "Notes" entity) and then save the form, it saves properly.  However, if I go back and edit that form and then click save, a duplicate of the image that I had previously added is also saved.

 

I believe this is a PowerApps bug.

3 REPLIES 3
Anonymous
Not applicable

Bug -- Removing item from "Attachments" field doesn't work in certain scenario

I have created an app with a form connected to a CDS entity. The CDS entity is set to "Allow attachments". When I add an image to the attachment field (which comes from the "Notes" entity) and then save the form, it saves properly.  However, if I edit the form, then delete one of the attachments by clicking the "x" next to it and then click Save, the attachment is not being removed in the saved form.  In order for the attachment to be removed, I have to click the "x" and then make a change to a different field in my form and click save.

 

I believe this is a powerapps bug.

Highlighted
Community Support Team
Community Support Team

Re: Bug -- Editing a form with "Attachments" and then saving causes duplicates

Hi @Anonymous,

Could you please share a bit more about the issue on your side?

Do you mean that a duplicated image would be saved into the same record when you edit and save the previous record?

 

I have made a test, and the issue is confirmed on my side. I would post this issue to my product team, if the issue is solved, I would reply here.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Rbert83
Level: Powered On

Re: Bug -- Editing a form with "Attachments" and then saving causes duplicates

I’m having this problem too.  Exactly how tgiard explained it. I also noticed that when I go the CDS and try to open the “notes” entity in excel, the file just gets locked up on trying to pull the data. 

Please let us know if this is a know bug and if its being worked on.  We have several apps in production that are affected by this issue. 

Thank you. 

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,190)