cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
PaulD1
Super User
Super User

Bug: First Radio button not selectable

This appears to have been the case for a few weeks now for me... On both Edge and Chrome, the first item in a set of radio buttons cannot be selected unless you click below and to the right of the radio button by a wide margin.

 

All other radio buttons (other than the first) appear to work fine.

 

Attached is a video clip showing the issue. You can't see when I'm clicking, but I'm trying repeatedly to select the first Radio button by clicking on the button or the label. Only when I click well below the label and to the right of the button does it finally select.

1 ACCEPTED SOLUTION

Accepted Solutions
v-xida-msft
Community Support
Community Support

Hi @PaulD1,

Do you mean that you could not click the first option within a set of Radio buttons?

I have made a test on my side, and don't have the issue that you mentioned. The GIF screenshot as below:Test1.gif

Please take a try to turn off/disable the "Improved app rendering (final validation)" option within Advanced settings of Apps settings of your app, then re-load your app, then check if the issue is solved.

If the issue still exists, please consider take a try to remove the Radio button and re-create a new one, the check if the issue still exists.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
v-xida-msft
Community Support
Community Support

Hi @PaulD1,

Do you mean that you could not click the first option within a set of Radio buttons?

I have made a test on my side, and don't have the issue that you mentioned. The GIF screenshot as below:Test1.gif

Please take a try to turn off/disable the "Improved app rendering (final validation)" option within Advanced settings of Apps settings of your app, then re-load your app, then check if the issue is solved.

If the issue still exists, please consider take a try to remove the Radio button and re-create a new one, the check if the issue still exists.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks @v-xida-msft

I tried with Improved App rendering enabled and disabled and still could not select the first element in a set of radio buttons in this App (other than by clicking well below/to the right of the first button). I have several sets of radio buttons in the app and all display the same issue, though curiously I have not seen the issue in any of my other Apps.

It seems that, if I filter the items property of the radio buttons such that the first element of the source is excluded, I can then click the first shown radio button... very strange.

I'll try deleting and recreating the radio buttons and report back the results.

Thanks

Paul

Recreated the affected Radio Buttons and now seems to be working OK.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Difinity Conference 2022

Difinity Conference 2022

Register today for two amazing days of learning, featuring intensive learning sessions across multiple tracks, led by engaging and dynamic experts.

European SharePoint Conference

European SharePoint Conference

The European SharePoint Conference returns live and in-person November 28-December 1 with 4 Microsoft Keynotes, 9 Tutorials, and 120 Sessions.

Power Apps Ideas

Check out the New Ideas Site

We are excited to announce a new way to share your ideas for Power Apps!

Top Solution Authors
Top Kudoed Authors
Users online (5,290)