cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Kudo Commander
Kudo Commander

Bug? PowerApps Rich Text Editor control changes hostname in links to powerapps

Hi,

 

We have a PowerApp with several Rich Text fields based on fields that ar Multiple lines of text with Rich Text enabled.

 

Our users have noticed that if a URL is added to the field using the link utton on the Rich Text toolbar, the link is changed.

It seems that the hostname of the link url is changed to

 

so: we enter (using the link control on the rich text toolbar):

https://bhfonline.sharepoint.com/:w:/r/teams-and-projects/dev/SharedDocuments/Contracts%20Database/Documentation/Contracts%20Database%20Transfer%20Script%20Documentation.docx?d=w995907cc73b44c75941a5964b1a287dd&csf=1&e=O1nrt2

PowerApps changes the hostname and the link becomes:

https://powerapps-ux-prod-ukwest.azureedge.net/:w:/r/teams-and-projects/dev/SharedDocuments/Contracts%20Database/Documentation/Contracts%20Database%20Transfer%20Script%20Documentation.docx?d=w995907cc73b44c75941a5964b1a287dd&csf=1&e=O1nrt2

here is an image of the link adder control in the RICH TEXT FIELD

 

BUG IN PA RICH TEXT CONTROL2.png

 

 

so what is this?

 

  • Is this a known bug that MS is fixing?
  • Are we/our users doing something wrong by clicking and using the link button in the Rich Text Control to add a link
  • Is there a workaround?

BTW, in case you're wondering - our link should point to our online SharePoint Tenant as you can see in the first pasted link

 

here is an image showing what we mean:

 

 

BUG IN PA RICH TEXT CONTROL.png

 

 

4 REPLIES 4
Highlighted
Community Support
Community Support

Hi @livingstonep ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:5.JPG

 

6.JPG

 

Please check if you have configured a proper Rich Text Editor control within your Edit form. 7.JPG

Note: The Description field is Multiple line text type column, which enables the Rich Text functionality

 

If the issue still exists, please consider re-create a new app based on your SP List, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted


@v-xida-msft wrote:

Hi @livingstonep ,

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The screenshot as below:5.JPG

 

6.JPG

 

Please check if you have configured a proper Rich Text Editor control within your Edit form. 7.JPG

Note: The Description field is Multiple line text type column, which enables the Rich Text functionality

 

If the issue still exists, please consider re-create a new app based on your SP List, then check if the issue is solved.

 

Best regards,


Hi,

Thanks for your response.

 

Please could you see what happens to the links after you Save, Close, and Re-Open the form.

 

Please note that this issue ONLY APPLIES TO SECURE SHAREPOINT TENANT SITES - WE HAVE NO PROBLEM WITH SITES LIKE GOOGLE, BBC NEWS, WIKIPEDIA

 

We have made the chnages suggested by you...

When we paste the link into the field, we can open the link properly.

We then Save the form, which closes it.

When we re-open the record in View/Edit mode, the links for our SharePoint Tenant (like sharted documents) have been changed.

 

Example:

https://bhfonline.sharepoint.com/teams-and-projects/dev/lab/CabApplicationImportTestSite/Lists/CABSubmissions/AllItems.aspx

is changed to:

https://powerapps-ux-prod-ukwest.azureedge.net/teams-and-projects/dev/lab/CabApplicationImportTestSite/Lists/CABSubmissions/AllItems.aspx

so please would you check what happens with links to your SharePoint Tenant folders AFTER save.

 

PLEASE NOTE:

The PowerApp is saving the links correctly into the SharePoint List - see below:

 

BUG IN PA RICH TEXT CONTROL3.png

 

thanks

Philip

Highlighted
Regular Visitor

The bug still persists in PowerApps.
The links are correctly saved in the SharePoint list. When using the default form, the link is not altered and is therefore functional.
However, once the SharePoint form is modified in PowerApps or in a PowerApps application separate from the SharePoint list, the link is altered. The beginning of the address containing 'sharepoint.com' is replaced, in my case, by 'pa-content-azrureedge'.

Highlighted

Hi Phillip

Have you found a solution to this. Im having a similar problem

Regards

Glenn

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (13,185)