cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
mr-dang
Community Champion
Community Champion

Bug: (Serious!) Formulas for Text converting to text

This bug affects the latest version of PA 2.0.660.

Normally you can edit a Textbox in two ways:

  1. Click a textbox and then change its Text property in the formula bar or advanced panel.
  2. Click a textbox, then click it again so you can edit the text directly. This requires at least 2 clicks.

If you place a formula in the textbox (method1), then later decide to use method 2, then you will overwrite the formula. That's expected. Since it's expected, you know to avoid it by not clicking twice.

 

But in the new version of PA, a single click on a textbox seems to be changing formulas in textboxes to basic text. Either a direct click on the textbox or clicking on it in the lefthand panel is messing things up. Something about the click has gotten very sensitive. I'm losing text and tooltips left and right!

 

Here's a video that replicates it:

https://drive.google.com/open?id=0B0iHNZhZKR6YRGVXQlRVM0pmTTQ

 

Pretty much as soon as you click any textbox, it will convert to text later. It's doomed.

 

Can you issue a hotfix? This makes apps unsafe for editing.

Microsoft Employee
@8bitclassroom
14 REPLIES 14
mr-dang
Community Champion
Community Champion

Note: in the video, I originally thought clicking on an object nearby is what messed up the text. It turns out as soon as you click the textbox, it will later convert so it doesn't seem related to clicking objects nearby.

Microsoft Employee
@8bitclassroom
Fields
Helper V
Helper V

Hi @mr-dang,

 

I also noticed that! It's annoying, for now, what i do is, change the text, and save imidiatly! It's not the best approach, but it helps! I hope they fix this issue!

 

They should do another forum, for bugs only! Until now, you have a +1 from me!

Anonymous
Not applicable

Yes this is a terrible glitch. I hope they patch it soon!

 

I have encountered this bug in:

  • label - text field
  • button - text field
mr-dang
Community Champion
Community Champion

I am leaning back towards my first hypothesis that the bug may be related to clicking nearby objects.

 

I have timers and buttons layered in the back of some other things I've been editing. I noticed that the timers weren't counting but that was incorrect. It seemed that way because their text property had been changed to static text--"00:00:00" instead of Text(Timer1.Value,"hh:mm:ss"). And I know I didn't edit that control nor its property--it's not too often that you decide to change the text of a timer.

 

Here's a list of things that have encountered the bug so far:

  • label (textbox) text property
  • button tooltip
  • timer text property
Microsoft Employee
@8bitclassroom

Thank you for reporting this issue!

 

We are looking into this issue. Meanwhile can you provide what version of Windows you are using (Windows 8.1 or Windows 10)? Have you tried using the authoring experience on the web (you can access this the PowerApps portal at https://web.powerapps.com and click edit on your app). If you have tried the web experience can you reproduce the issue there?

 

In addition, if you have a smaller set of steps that you've found that consistenly reproduces this issue we would be very interested.

 

Thanks!

mr-dang
Community Champion
Community Champion

Hi, 

It took a while, but I got it consistently in a blank app:

 

Video

https://drive.google.com/file/d/0B0iHNZhZKR6YTEdDVXd0aTFuMk0/view?usp=sharing

 

.msapp File
https://drive.google.com/file/d/0B0iHNZhZKR6Ybi1IaHdGLXNDQmc/view?usp=sharing

 

Here's steps on how to use the msapp file to get the bug

  1. Click the label to see everything is working.
  2. Switch the toggle
  3. Click the label again to see everything is working
  4. Switch the toggle
  5. Click the label again to see that everything has been changed to text

 

This is my thinking:

  • The objects must have a formula in their text or tooltip properties that change
  • The objects seem to have height/width/x/y positions that shift: Edit: I retested this setting the Y to a fixed number and the bug was still reproducible
  • The objects are near other objects--it could be a layering issue. The timer was above the label and did not bug. Edit: If I run the steps with the timer instead of the label, the timer bugs, but the label is okay. One thing bugs at a time
Microsoft Employee
@8bitclassroom
mr-dang
Community Champion
Community Champion

Note: it is interesting that the bug can be undone using Ctrl+Z. There must be an action activating somewhere

Microsoft Employee
@8bitclassroom
mr-dang
Community Champion
Community Champion

@ADobin

I forgot to mention, I am on Windows 10 Creators Update (not insider). The bug was reproducible on the web editor as well.

Microsoft Employee
@8bitclassroom

Thank you for all of the information @mr-dang! We've identified the issue and are working to resolve it.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,796)