cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Bug : Sharepoint and PowerApps

Hello PowerApps team, 

 

I am ruuning out of ideas for this one. 

 

Context : I have built a PowerApps solution using a Sharepoint List data source .I have a Submit Button which has been set to SubmitForm1(formname2);SubmitForm2(formname2).

 

Issue 1: When my users click on the Submit button, some times the data they have submitted is lost and reverts back to the old data set. And some times when they click submit they get an error " There was a problem saving your changes. The data source may be invalid". And furthur error "Conflicts Exist with changes on the server, please reload. Server response : ETAG mismatch. ....".

 

Based on some of the response I saw, we added a fix Refresh('DataSource');SubmitForm1(formname2);SubmitForm2(formname2) for Submit button. It seemed to have fixed but now we are getting the same error again. 

 

The first time we saw the issue was when we submit a data chosen by the user using the data picker. The time zone was set to local. 

 

Also would like to point out there were times when we got the above error, when refreshed the page the values were present in the form. 

 

PLEASE HELP !! 

 

 

13 REPLIES 13

Based on what you said @Pstork1 I have now updated the Submit button with only one SubmitForm(FormName) I am still getting the same error. 

 

i.e OnSelect : SubmitForm(Formname1)

Dual Super User III
Dual Super User III

Then I'm not sure why you are getting the error.  I would need to know a lot more about the way your app is built to suggest any other fixes.  That was the obvious one.  There has to be something else going on in the form that is trying to interact with the connector that is causing the issue. I would start by looking at any of the spots in the form where you have modified the default formulas to adjust data.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

@Pstork1 The only 'if' condition I have is for updating a RAG status with the relevant value. Is there a way in which I could know the setting for the connector? 

Dual Super User III
Dual Super User III

Its not just if conditions you need to examine.  Any function where you are changing the data could cause an issue.  For example you mentioned something about a data picker and setting it for local timezone.  How are you doing that? And anything else like that.

 

I'm also not sure what you mean by the "setting for the connector". 

 

The other thing I will go back to is that you would have much more control if you do your submission using a Patch statement rather than submitting a form with bound data.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (13,907)