cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
wkaper1
Regular Visitor

Bug? Simple CRUD API: strange function signature using PUT function

I have a custom API that does GET, POST, PUT and DELETE actions on a single type of items.

This question / bug report is about the PUT function.

I registered the custom connector and it shows the PUT function correctly as in the below screenshot.Connector_Definition_Put.PNG

 

As the screenshot shows there are two parameters:

- id

- A record that contains four properties: Title, ToDoID, Priority, Done

 

If I try to use this function inside PowerApps, it shows me a different signature, as the next three pictures will show.

 

 

 

 

 

 

 

 

 

 

PowerApp shows it expects two parameters, called "id" and "Title", see screenshot 2 below:

ToDoes_PUT_param1_of_3.PNG

After I add the requested Title as in screenshot 3, it becomes clear that a third parameter is expected which is a record.

 

 

 

 

 

 

 

 

 

 

Screenshot 3: a Record is expected as a third parameter:ToDoes_PUT_param3_of_3_initial.PNG

 

 

The expected contents of the record are shown between the curly braces, as below:

{ ToDoID: number, Priority: number, Done: Boolean }

 

 

 

 

 

 

 

My question: why is the "Title" property not inside the curly braces?

That would be consistent with the design of the API as well as consistent with the connectors view of the API.

Can I call it a bug? O a design problem? It does not seem consistent.

 

This PowerApp works though !

I can update the "Title", if I complete the formula as below (screenshot 4).ToDoes_PUT_param3_of_3_final.PNG

 

 

If you want to reproduce the shown symptoms, see the details below:

 

 

 

 

 

 

 

 

 

 

The API is here:

http://entocaretodoapi.azurewebsites.net/

It's public at the moment.

 

It's swagger file is at:

http://entocaretodoapi.azurewebsites.net/swagger/docs/v1

 

With best regards,

wkaper1

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
v-micsh-msft
Community Support
Community Support

Hi @wkaper1,

 

I replied your issue in another thread:

https://powerusers.microsoft.com/t5/PowerApps-Forum/Bug-Simple-CRUD-API-strange-function-signature-u...

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

1 REPLY 1
v-micsh-msft
Community Support
Community Support

Hi @wkaper1,

 

I replied your issue in another thread:

https://powerusers.microsoft.com/t5/PowerApps-Forum/Bug-Simple-CRUD-API-strange-function-signature-u...

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,859)