cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

Hi there,

 

Following an issue I had that others also had (details here : https://powerusers.microsoft.com/t5/Building-Power-Apps/Button-selected-fill-colour-remains-active-a... ) I’ve now managed to boil down where the issue is actually occurring and hence hopefully the bug can be fixed.

 

In summary had started to see an issue on Android device(s) in apps that were working fine before suddenly sometime in recent month or two started to show any buttons as staying “pressed” when clicked .. i.e. when clicked the fill colour changes but was NOT changing back when released so appearing disabled.

 

After extensive investigations trying different builds, different versions of PowerApps client, clearing caches, etc., I got a clue when I managed to clear the issue with a hard reset of the device(s) returning to factory setting. Then by a tortuous process of one-by-one updating of other apps, settings, etc., combined with creating very basic new app (step by step stripping out bits from one of the apps that was showing the issue) I’ve been able to replicate the issue to order and isolate the cause ..

 

It appears there’s bug with PowerApps client for Android when running with Android.System.Webview version 80 or above [which can be introduced by updates to Chrome on Android as this automatically updates Android.System.Webview] and is in fact the way I found it as at first it appeared it be a conflict with updates to Chrome that was causing the problem.

 

To duplicate/replicate this issue, create a new canvas phone app with just a button on it and a text input field .. when run (with Android.System.Webview >= v80) clicking on the button multiple times works fine and it’s fill colour reacts fine (down/up etc) but as soon as you click and focus on the text field as though to make an entry in it and then subsequently when clicking the button it stays “pressed” as the fill colour doesn’t change back. If you then revert the Android.System.Webview back to v79 or earlier the app works fine and focusing into the text input then clicking on the button it’s fill colour reacts as it should.

 

For reference I tried a few versions of Android.System.Webview with the last one that worked being v79.0.3945.116 and the first where the issue appeared being v80.0.3987.87 and any subsequent one also a problem including latest v81.

 

Hopefully someone from the PowerApps team will see this and investigate this as it’s a serious issue and will likely affect any apps that have buttons and text input fields on Android as devices update to latest versions of Chrome, many automatically.

 

Derek

 

6 REPLIES 6
Highlighted
Advocate II
Advocate II

Re: Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

Hi there,

 

Just wondered if anyone in the Microsoft PowerApps team had seen this as there hasn't been any response and I believe this to be a bug that will affect large number of users/apps on Android as auto updates roll out?

 

It also raises the question as to whether there's a more formal or efficient way to report bugs that can be used? Posting in here is great and useful for many things but the shear volume of posts means it must be difficult for the PowerApps team to keep up with reviewing posts and likely that bugs might be missed.

 

To be honest it's also somewhat deflating when one puts a lot of time and effort into investigating an issue from our end (as with this) and then having found the (probable) cause to have the details of investigations lost within the volume of other posts, which is obviously no fault of the PowerApps folks but it would be good all round if there was a separate process for actual bug reporting?

 

Derek

Highlighted
Frequent Visitor

Re: Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

Hi,

 

I have been having the exact same problem with my first powerapp. I had also noticed that the buttons on my main screen work fine until I navigate to my second screen which has Text Input boxes and I enter text into one of them. After doing that the buttons start playing up both on the screen with the text inputs and back on my main screen which has none. I have to shut down and re-open PowerApps to get it to stop.

 

I also hope Microsoft get this sorted out quickly because if it does not get sorted out in the next few weeks I will have to demonstrate a faulty app to my management team. The app is being developed rapidly for use by government employees and if it has a flaw like this in it then it will never be accepted and that will kill any chance of PowerApps being deployed for this job or others like it in the future. The risk of embarrassment will not be worth it.

Highlighted
Advocate II
Advocate II

Re: Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

Hi @AtomicPete 

 

Obviously hoping they fix this soon as it will affect more and more apps/folks as Android phone updates roll out but something they may help you as a temporary workaround for development and demonstration to your management ..

 

It's possible to roll-back the Android.System.Webview to the factory installed version which in most cases (unless very new phone) should be prior to version 80.xxx which is where the issue seems to start from as follows :

 

Go to Settings / Apps then make sure the "Show system apps" is selected from hamburger menu .. scroll down to Android.System.Webview and click on it to open .. at the bottom you can can see the current version installed and I'm guessing it's 80.xxx or 81.xxx ... then there should be a hamburger menu at the top (if updates have been installed) with the option to "Uninstall updates" which will replace with the factory version [note: it's easy to just update back using Google Play if needed as it will show up as update to install] .. then scroll down to see the factory installed version for confirmation which is hopefully less that 80.xxx (ie. 79.xxx or earlier) .. then try your app and hopefully should work fine. If so, you can confirm it's this causing the issue as re-updating Android.System.Webview to latest version should re-introduce the bug.

 

Let me know if that results in expected behaviour and hence confirms the bug diagnosis and additionally helps with you presentation! 🙂  

 

Derek

Highlighted
Frequent Visitor

Re: Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

Hi @DerekPapworth 

 

I had a look to see if I could roll back my version of Android.System.Webview but the option is not there. It might be because I have a Huawei phone which did not come with all of the Google stuff factory loaded. The phone shop loaded most of it for me.

 

But I will ask a colleague to try my app at work next week with their phone and see if they can test it on a rolled back version.

 

Thanks

 

 

Highlighted
Frequent Visitor

Re: Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

@DerekPapworth 

 

I got a reply from Microsoft to another post that I made about this issue. They have confirmed that they know about it and are working on it. Hopefully it will be fixed soon. The other post is here:

 

https://powerusers.microsoft.com/t5/Building-Power-Apps/Bug-Button-controls-on-Android-devices-getti...

 

Highlighted
Frequent Visitor

Re: Bug in PowerApps for Android when running with recent versions (>= v80) of Android.System.Webview - buttons staying "pressed"

This also happens on my laptop when I run apps in Chrome and use the touchscreen. The issue doesn't happen when using Edge.
Obviously doesn't help the Mobile issue, but supports the view that the issue could be Chrome related. 

Helpful resources

Announcements
Ignite

Microsoft Ignite

This will be a conference that you do not want to miss!

secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,047)