cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Bug in PowerApps webpart

Hi all,

 

I've been testing the new PowerApps web part, and found some glitches and possible improvements ...

By the way, they are:

-When the PowerApp finishes loading, the focus switches to the iframe that its generated by it. So if you were seeing the top of the page and this webpart is in the bottom, the page scrolls down by itself

-We can't pass parameters to the PowerApp (which we could do normally using a link and was very useful)

 

Hope someone helps with this glitches, this webpart could potentially be a great addition to SharePoint online modern sites 🙂

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Re: Bug in PowerApps webpart

Hi @michelcarlo,

 

Thanks for your feedback. For your first issue, I have made a test and the issue is confirmed on my side. The web page would scroll to the embeded PowerApps app automatically when the PowerApps app is finishing loading. If you would like this feature to be improved, please submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

For your second issue, do you want to pass parameters to the embeded PowerApps app within your Web page? Currently, if you want to pass parameters to the embeded PowerApps app within your web page, you should add your custom parameters within the URL as below:

https://web.powerapps.com/webplayer/iframeapp?source=iframe
&appId=/providers/Microsoft.PowerApps/apps/[AppID]&param1=value1&param2=value2

Then you could use the Param() function to retrieve these parameters within your PowerApps app. 

 

More details about setting URI parameters for your PowerApps app, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/embed-apps-dev#set-uri-parameters-for-y...

 

If you want to pass parameters to the embeded PowerApps app in your web page without adding custom parameters within the URI, please consider submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

3 REPLIES 3
Highlighted
Community Support
Community Support

Re: Bug in PowerApps webpart

Hi @michelcarlo,

 

Thanks for your feedback. For your first issue, I have made a test and the issue is confirmed on my side. The web page would scroll to the embeded PowerApps app automatically when the PowerApps app is finishing loading. If you would like this feature to be improved, please submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

For your second issue, do you want to pass parameters to the embeded PowerApps app within your Web page? Currently, if you want to pass parameters to the embeded PowerApps app within your web page, you should add your custom parameters within the URL as below:

https://web.powerapps.com/webplayer/iframeapp?source=iframe
&appId=/providers/Microsoft.PowerApps/apps/[AppID]&param1=value1&param2=value2

Then you could use the Param() function to retrieve these parameters within your PowerApps app. 

 

More details about setting URI parameters for your PowerApps app, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/embed-apps-dev#set-uri-parameters-for-y...

 

If you want to pass parameters to the embeded PowerApps app in your web page without adding custom parameters within the URI, please consider submit an idea to PowerApps Ideas Forum:

https://powerusers.microsoft.com/t5/PowerApps-Ideas/idb-p/PowerAppsIdeas

 

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Advocate I
Advocate I

Re: Bug in PowerApps webpart

Thanks for your reply.

I've tried putting parameters in a different format (which worked on the browser directly) but the WebPart rejected my link. Will test using this new one. I'm going to post the suggestion too. 

Highlighted
Advocate III
Advocate III

Re: Bug in PowerApps webpart

Hi - did anyone get parameters working in the new PowerApps webpart?

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Tech Marathon

Maratón de Soluciones de Negocio Microsoft

Una semana de contenido con +100 sesiones educativas, consultorios, +10 workshops Premium, Hackaton, EXPO, Networking Hall y mucho más!

Top Solution Authors
Top Kudoed Authors
Users online (5,870)