cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sravyabollineni
Frequent Visitor

Button click Call Custom connector

I have Save button on my page. I would like to save the details on the page on click of the Save button.

I have a custom connector which is taking a collection object as an input parameter and is able to post the details aptly.

 

I am trying to give this custom connector in OnSelect event of the button. But it is not allowing me to.

Is it possible to call custom connectors in OnSelect event or do I need to trigger a power automate flow(which calls the api) on OnSelect.

 

Any help much appreciated!! 

1 ACCEPTED SOLUTION

Accepted Solutions
CNT
Super User
Super User

@sravyabollineni You can call custom connectors directly from Power Apps. If you are not the Owner make sure it has been shared with you by the owner. Then add it into your App as you would add any other data source and call the functions provided by the connector passing any parameter, if required. Hope this helps!

View solution in original post

9 REPLIES 9
CNT
Super User
Super User

@sravyabollineni You can call custom connectors directly from Power Apps. If you are not the Owner make sure it has been shared with you by the owner. Then add it into your App as you would add any other data source and call the functions provided by the connector passing any parameter, if required. Hope this helps!

View solution in original post

@CNT  Happy to know that it's possible.

Could you please help me sort this out. Below is the message I see when I try to bind the function in OnSelect event of a button, while the custom connector works perfectly fine.

sravyabollineni_0-1621715203418.png

 

 

 

@sravyabollineni Is UpdatePersona the name of your custom connector? have you added it to your App?

I am struggling with this error for a very long time.

I have even tried removing the parameters to the API just to make sure that the custom connector is parameter free and the failure has nothing to do with the parameters being passed. Now it is just the UpdatePersona.Properties in OnSelect event. The custom connector works perfectly fine but I am unable to make the call happen from Powerapps.

 

Any help here much appreciated !!

@sravyabollineni I'm more than happy to help. But you have not answered my question,

Is UpdatePersona the name of your custom connector? have you added it to your App?

@CNT That's right! UpdatePersona is the custom connector. Properties is my Operation name. What does it mean by adding to the app? When I try to bind it with a Gallery, or a dropdown it shows up in the data sources, but a button OnSelect event doesn't show any of the connectors.

 

Here is what the custom connector looks like.

sravyabollineni_0-1621751425572.png

 

@sravyabollineni You should add it like any other connector. Is it showing up there?

CNT_0-1621751749004.png

 

@CNT 

It worked on refreshing the session multiple times. In fact, I had to start a whole new session, only then the custom connector started showing up in the app. I also had to wait for some time. Looks like there is some problem with how the refreshing works

@sravyabollineni Glad that it works for you!

 

Please remember to give a 👍 and accept the solution as it will help others in the future.

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,742)