cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Mrsprofitt77
Level: Powered On

CDS memo type field not displaying in PowerApp

I have a custom entity called Bikes which includes a Text field called Long description. The length property on the field is set to 4000 and it is my understanding that the CDS stores this as a Memo type field in the DB. I created a Power App that has multiple pages. On the Bike details page I have a form that is displaying several fields from the Bikes entity. However, the Long description field does not display any data. I have tried using a custom card with both an HTML and a rich text field, but still the data does not display. Attached are some screen shots of the field in the CDS and the Form on the PowerApp.

 

LongDescription.pngLong description field on the CDS entity Bikes

LongDescriptionApp.pngLong description data card on the Details form

 

1 ACCEPTED SOLUTION

Accepted Solutions
Mrsprofitt77
Level: Powered On

Re: CDS memo type field not displaying in PowerApp

So we figured out the problem. The previous screen on the PowerApp was a gallery of the bikes. When you selected a bike, we set a global variable to the selected bike. On the Bike details page we displayed the additional fields for the selected bike by setting the items property to the global variable for the bike. Most of the fields displayed, but many did not.

 

Turns out that the only fields that worked and displayed data were from the previous screen and fields that were displayed on the form. To correct the issue, we added the URL and Long description fields and then made the visible property false so you could not see them. When the global variable was set, it was only populating the fields that were already retrieved in the form. It kind of makes sense from a data performance perspective, but was not super intuitive. Maybe there is another way to achieve, but that is how we solved the problem. It was just odd because the only two fields that did not display were both memo type fields - so I assumed the issue was related to the length of the fields.

View solution in original post

3 REPLIES 3
Community Support Team
Community Support Team

Re: CDS memo type field not displaying in PowerApp

Hi @Mrsprofitt77 ,

Could you please share a bit more about your issue?

Do you mean that the "Long description" column value could not be displayed within the Edit form/Display form of your app?

 

Based on the needs that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. Please check if the "Long description" column value of current record you are opening is Blank.

According to the screenshot that you mentioned, it seems to tell that the "Long description" column value is Blank for current record. Please make sure the Text property of the "Long description" Label to following:

ThisItem.'Long description'

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Mrsprofitt77
Level: Powered On

Re: CDS memo type field not displaying in PowerApp

The Text property is set to Parent.Default. The Data Field property is set to the name of the field in the CDS. I selected the field from the field selector on the right side when I added the form. All the other fields display from except for the Long description and the URL. I was assuming this is because both fields are very long. URL is 400 characters, and the Long description is 4000.

 LongDescriptionDataField.pngLong Description field properties

Mrsprofitt77
Level: Powered On

Re: CDS memo type field not displaying in PowerApp

So we figured out the problem. The previous screen on the PowerApp was a gallery of the bikes. When you selected a bike, we set a global variable to the selected bike. On the Bike details page we displayed the additional fields for the selected bike by setting the items property to the global variable for the bike. Most of the fields displayed, but many did not.

 

Turns out that the only fields that worked and displayed data were from the previous screen and fields that were displayed on the form. To correct the issue, we added the URL and Long description fields and then made the visible property false so you could not see them. When the global variable was set, it was only populating the fields that were already retrieved in the form. It kind of makes sense from a data performance perspective, but was not super intuitive. Maybe there is another way to achieve, but that is how we solved the problem. It was just odd because the only two fields that did not display were both memo type fields - so I assumed the issue was related to the length of the fields.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Users online (5,501)