cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Super User
Super User

CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

Hello, 

 

I'm creating a custom connector and have everything in order (I believe). When I test the connector I get the error: "Request failed. Please try again in a few minutes.". It happens in a split second like the POST request is not even trying to run. 

It doesn't respond with a 404, 403, etc. 

 

The Request appears to be all formed and good to go: 

requestIssue.png

 

The Response is completely blank:

responseIssue.png

 

Any ideas? 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

Thank you for the detailed response.

 

In the end, I think the issue was: I connected to the company VPN while testing. Once disconnected, I then received a 404 which I was able to troubleshoot. 

 

 

View solution in original post

5 REPLIES 5
Microsoft nickdurak
Microsoft

Re: CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

Hello,

 

The error you are seeing occurs when the brower is unable to make the request due to the OPTIONS call failing. I recommend checking your outgoing requests and looking for the OPTIONS call for this particular request to verify it is indeed a CORS issue. For more information on CORS, see the following documentation: https://developer.mozilla.org/en-US/docs/Web/HTTP/CORS

 

Which API are you attempting to call? You will need to update the CORS rules for that API. If you are trying to call an Azure Function, you can try disabling CORS by only having one entry of “*”
https://docs.microsoft.com/en-us/azure/azure-functions/functions-how-to-use-azure-function-app-setti...

 

Super User
Super User

Re: CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

Thank you for the detailed response.

 

In the end, I think the issue was: I connected to the company VPN while testing. Once disconnected, I then received a 404 which I was able to troubleshoot. 

 

 

View solution in original post

Super User
Super User

Re: CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

Bummer. Happening again 7 months later... don't know why! This time i'm not on the VPN... Been waiting ~30 mins.

image.png

james_p_barry
Level: Powered On

Re: CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

I have a new custom connector setup correctly and working for a POST (create).  But when I try the same for a PUT (update), I get this error, "Request failed. Please try again in a few minutes."  What could be the cause of this?  Again, POST works great, but PUT fails.

Super User
Super User

Re: CUSTOM CONNECTOR: "Request failed. Please try again in a few minutes."

Hi @james_p_barry , i'm not sure how this resolved for me the second time. I either waited a day or so and it just worked OR i recreated the Custom Connector. 

Curious how you fared.

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (9,040)