cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
AdamGill
Resolver II
Resolver II

Calculations not Displaying

Hi!

I have some long computations which display in Studio - but not on the Published version. It used to work fine - not sure what has happened in the meantime. See screenshot below. One of the computations is shown below - it is quite long - but also very,very straightforward:

 

"$"&Value(TextInput2_1+
TextInput2_2+
TextInput2_3+
TextInput2_4+
TextInput2_8+
TextInput2_14+
TextInput2_15+
TextInput2_16+
TextInput2_17+
TextInput2_18+
TextInput2_19+
TextInput2_20+
TextInput2_21+
TextInput2_23+
TextInput2_24+
TextInput2_25+
TextInput2_27+
TextInput2_28+
TextInput2_29+
TextInput2_30+
TextInput2_31+
TextInput2_32+
TextInput2_33+
TextInput2_34+
TextInput2_35+
TextInput2_36+
TextInput2_38+
TextInput2_39+
TextInput2_40+
TextInput2_41+
TextInput2_42+
TextInput2_43+
TextInput2_44+
TextInput2_45+
TextInput2_46+
TextInput2_48+
TextInput2_49+
TextInput2_50+
TextInput2_51+
TextInput2_52+
TextInput2_53+
TextInput2_54+
TextInput2_55+
TextInput2_56+
TextInput2_57+
TextInput2_58+
TextInput2_59+
TextInput2_60+
TextInput2_61+
TextInput2_63+
TextInput2_64+
TextInput2_65+
TextInput2_66+
TextInput2_67+
TextInput2_68+
TextInput2_69+
TextInput2_70+
TextInput2_71+
TextInput2_72+
TextInput2_73+
TextInput2_74+
TextInput2_75+
TextInput2_76+
TextInput2_77+
TextInput2_78+
TextInput2_79+
TextInput2_80+
TextInput2_81+
TextInput2_82+
TextInput2_83+
TextInput2_84+
TextInput2_85+
TextInput2_86+
TextInput2_87+
TextInput2_88+
TextInput2_89+
TextInput2_90+
TextInput2_91+
TextInput2_92+
TextInput2_93+
TextInput2_94 +
TextInput2_95 +
TextInput2_96 +
TextInput2_97 +
TextInput2_98 +
TextInput2_99 +
TextInput2_100 +
TextInput2_101 +
TextInput2_102 +
TextInput2_103 +
TextInput2_104 +
TextInput2_105)
&".00"

 

PA1.png

 

Any ideas, please?
Thanks!

Adam

1 ACCEPTED SOLUTION

Accepted Solutions

Apparently, it was my Chrome Browser. Works fine in MS Edge....

View solution in original post

3 REPLIES 3
CarlosFigueira
Power Apps
Power Apps

You can try converting every text input to a number prior to adding them. What is probably happening is that in Studio the "+" operation is silently converting from text to a number, but in the player it is not - I don't know what should be the correct behavior. If you update your expression to the one below, I believe you should see the same result on both studio and player:

"$" &
    Value(TextInput2_1.Text) + Value(TextInput2_2.Text) + Value(TextInput2_3.Text) +
    Value(TextInput2_4.Text) + Value(TextInput2_8.Text) + Value(TextInput2_14.Text) +
    Value(TextInput2_15.Text) + Value(TextInput2_16.Text) + Value(TextInput2_17.Text) +
    Value(TextInput2_18.Text) + Value(TextInput2_19.Text) + Value(TextInput2_20.Text) +
    Value(TextInput2_21.Text) + Value(TextInput2_23.Text) + Value(TextInput2_24.Text) +
    Value(TextInput2_25.Text) + Value(TextInput2_27.Text) + Value(TextInput2_28.Text) +
    Value(TextInput2_29.Text) + Value(TextInput2_30.Text) + Value(TextInput2_31.Text) +
    Value(TextInput2_32.Text) + Value(TextInput2_33.Text) + Value(TextInput2_34.Text) +
    Value(TextInput2_35.Text) + Value(TextInput2_36.Text) + Value(TextInput2_38.Text) +
    Value(TextInput2_39.Text) + Value(TextInput2_40.Text) + Value(TextInput2_41.Text) +
    Value(TextInput2_42.Text) + Value(TextInput2_43.Text) + Value(TextInput2_44.Text) +
    Value(TextInput2_45.Text) + Value(TextInput2_46.Text) + Value(TextInput2_48.Text) +
    Value(TextInput2_49.Text) + Value(TextInput2_50.Text) + Value(TextInput2_51.Text) +
    Value(TextInput2_52.Text) + Value(TextInput2_53.Text) + Value(TextInput2_54.Text) +
    Value(TextInput2_55.Text) + Value(TextInput2_56.Text) + Value(TextInput2_57.Text) +
    Value(TextInput2_58.Text) + Value(TextInput2_59.Text) + Value(TextInput2_60.Text) +
    Value(TextInput2_61.Text) + Value(TextInput2_63.Text) + Value(TextInput2_64.Text) +
    Value(TextInput2_65.Text) + Value(TextInput2_66.Text) + Value(TextInput2_67.Text) +
    Value(TextInput2_68.Text) + Value(TextInput2_69.Text) + Value(TextInput2_70.Text) +
    Value(TextInput2_71.Text) + Value(TextInput2_72.Text) + Value(TextInput2_73.Text) +
    Value(TextInput2_74.Text) + Value(TextInput2_75.Text) + Value(TextInput2_76.Text) +
    Value(TextInput2_77.Text) + Value(TextInput2_78.Text) + Value(TextInput2_79.Text) +
    Value(TextInput2_80.Text) + Value(TextInput2_81.Text) + Value(TextInput2_82.Text) +
    Value(TextInput2_83.Text) + Value(TextInput2_84.Text) + Value(TextInput2_85.Text) +
    Value(TextInput2_86.Text) + Value(TextInput2_87.Text) + Value(TextInput2_88.Text) +
    Value(TextInput2_89.Text) + Value(TextInput2_90.Text) + Value(TextInput2_91.Text) +
    Value(TextInput2_92.Text) + Value(TextInput2_93.Text) + Value(TextInput2_94 .Text) +
    Value(TextInput2_95 .Text) + Value(TextInput2_96 .Text) + Value(TextInput2_97 .Text) +
    Value(TextInput2_98 .Text) + Value(TextInput2_99 .Text) + Value(TextInput2_100 .Text) +
    Value(TextInput2_101 .Text) + Value(TextInput2_102 .Text) + Value(TextInput2_103 .Text) +
    Value(TextInput2_104 .Text) + Value(TextInput2_105.Text) &
    ".00"

Hope this helps!

Thank you for the very quick response!

Sadly, this made no difference. What I am also seeing is a series of calculations which simply do not display, anymore. They are all based on the same formula - some work and display correctly while some do not... 😞

Again - thanks!

Adam

Apparently, it was my Chrome Browser. Works fine in MS Edge....

View solution in original post

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (3,304)