cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Camera Widget not Working in Desktop App for Tablet or Computer

I have a camera widget that I use to snap images of documents. Everything works fine in the web app, but when I switch to the desktop version I have to minimize the app then maximize it to get an image to display.

 

There are two cameras on the device so I set the Camera property of the widget to "Cam" and set "Cam" to 0 on the AppStart using:

 

Set(Cam,0)

Then I can change the camera using another button where the OnSelect action has the following code:

 

Switch(Cam, 
    0, Set(Cam,1),
    1, Set(Cam,0),
)

I run it in my browser and it works fine, then I close everything and only open the power app and the camera initially just shows a white screen. I minimize the app and then maximize it for the image to show up. If I switch the Cam to 1 it just shows a black screen and when I switch it back to 0 I have to again minimize and maximize the app for it to show.

 

I've checked my permissions and everything has access to the camera and I've ensured to run the desktop version with the online one closed.

 

I've tested this on both a Windows 10 Dell Inspiron and a Windows 10 Dell Tablet.

Any suggestions?

2 REPLIES 2
Highlighted
Community Support
Community Support

Hi @Anonymous ,

 

Are you referring to the Widget mentioned in below blog?

https://flow.microsoft.com/en-us/blog/widgets/

If so, then it's rather a system level issuem not a PowerApps issue.

If not, please correct me in your next reply. You could explain with some screenshots. Do mask sensitive data before you upload.

 

Regards,

Mona

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Anonymous
Not applicable

Hi @v-monli-msft ,

 

I'm confused as to what you're referring to in that video. It seems to be referencing flows ability to connect to various applications that already exist.

 

I'm referencing the camera add-in inside of the PowerApps suite. I found another thread here that goes over all the issues I'm seeing: 

 

https://powerusers.microsoft.com/t5/Building-PowerApps-Formerly/Bugs-Microsoft-Store-Powerapps-Camer...

 

Thanks,

 

Sam

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,759)