cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sgerschutz
Frequent Visitor

Camera images not displaying in collection. Collection only showing broken links.

Hello,

I'm trying to populate a collection from a camera control. I am using the following code on a button

Collect(pics2,{img:Camera2.Photo});Navigate(LicenseScreen,ScreenTransition.Cover)

When I go to look at the collection it produces the attached image. I've tried changing the column name. I've additionally tried deleting and recreating the whole thing, to no avail. Any help would be appreciated. 

Thanks,

Steve

1 ACCEPTED SOLUTION

Accepted Solutions
PaulD1
Community Champion
Community Champion

If you are taking the photo from a button (rather than from the OnSelect of the camera control) you need to use the Stream property instead of the photo property, e.g. 

Collect(pics2,{img:Camera2.Stream});Navigate(LicenseScreen,ScreenTransition.Cover)

You also have to set the Stream rate property of the camera to 100.

Frustrating that it is inconsistent (Photo vs Stream) as this catches a lot of people out.

View solution in original post

5 REPLIES 5
PaulD1
Community Champion
Community Champion

If you are taking the photo from a button (rather than from the OnSelect of the camera control) you need to use the Stream property instead of the photo property, e.g. 

Collect(pics2,{img:Camera2.Stream});Navigate(LicenseScreen,ScreenTransition.Cover)

You also have to set the Stream rate property of the camera to 100.

Frustrating that it is inconsistent (Photo vs Stream) as this catches a lot of people out.

v-xida-msft
Community Support
Community Support

Hi @sgerschutz ,

Do you add another button control within your app to capture the pictures taken by Camera control?

 

Based on the issue that you mentioned, I think this issue may be related to your operation. The Camera control would take a picture only when you click the Camera control. If you press the another button to collect the pictures captured via the Camera control, the result the Camera2.Photo formula would return Blank (Just as the screenshot you provided).

 

As an fixed solution, please consider take a try with the following workaround:

Set the OnSelect property of the Camera control to following:

Collect(pics2, {img:Camera2.Photo})

Set the OnSelect propert of the Navigate Button control to following:

Navigate(LicenseScreen,ScreenTransition.Cover)

Please take  atry with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

You're a lifesaver! This fixed my issue flawlessly!

summitb
Power Participant
Power Participant

Try using stream as mentioned in the video below.

https://youtu.be/QNOEi-loNz8

summitb
Power Participant
Power Participant

Try using stream as mentioned in the video

https://youtu.be/QNOEi-loNz8

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Users online (4,068)