cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sgerschutz
Frequent Visitor

Camera images not displaying in collection. Collection only showing broken links.

Hello,

I'm trying to populate a collection from a camera control. I am using the following code on a button

Collect(pics2,{img:Camera2.Photo});Navigate(LicenseScreen,ScreenTransition.Cover)

When I go to look at the collection it produces the attached image. I've tried changing the column name. I've additionally tried deleting and recreating the whole thing, to no avail. Any help would be appreciated. 

Thanks,

Steve

1 ACCEPTED SOLUTION

Accepted Solutions
PaulD1
Super User
Super User

If you are taking the photo from a button (rather than from the OnSelect of the camera control) you need to use the Stream property instead of the photo property, e.g. 

Collect(pics2,{img:Camera2.Stream});Navigate(LicenseScreen,ScreenTransition.Cover)

You also have to set the Stream rate property of the camera to 100.

Frustrating that it is inconsistent (Photo vs Stream) as this catches a lot of people out.

View solution in original post

5 REPLIES 5
PaulD1
Super User
Super User

If you are taking the photo from a button (rather than from the OnSelect of the camera control) you need to use the Stream property instead of the photo property, e.g. 

Collect(pics2,{img:Camera2.Stream});Navigate(LicenseScreen,ScreenTransition.Cover)

You also have to set the Stream rate property of the camera to 100.

Frustrating that it is inconsistent (Photo vs Stream) as this catches a lot of people out.

View solution in original post

v-xida-msft
Community Support
Community Support

Hi @sgerschutz ,

Do you add another button control within your app to capture the pictures taken by Camera control?

 

Based on the issue that you mentioned, I think this issue may be related to your operation. The Camera control would take a picture only when you click the Camera control. If you press the another button to collect the pictures captured via the Camera control, the result the Camera2.Photo formula would return Blank (Just as the screenshot you provided).

 

As an fixed solution, please consider take a try with the following workaround:

Set the OnSelect property of the Camera control to following:

Collect(pics2, {img:Camera2.Photo})

Set the OnSelect propert of the Navigate Button control to following:

Navigate(LicenseScreen,ScreenTransition.Cover)

Please take  atry with above solution, then check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

You're a lifesaver! This fixed my issue flawlessly!

summitb
Power Participant
Power Participant

Try using stream as mentioned in the video below.

https://youtu.be/QNOEi-loNz8

summitb
Power Participant
Power Participant

Try using stream as mentioned in the video

https://youtu.be/QNOEi-loNz8

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (21,664)