cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Resolver I
Resolver I

Can't Open Model Driven Apps

I can create a model-driven app, but every time I try to open it - I get an error.

 

The requested record was not found or you do not have sufficient permissions to view it.

 
  • Timestamp: 1/9/2020 5:15:42 PM UTC
  • Service Request Id: c29177cf-9b60-4c42-9f6a-6176d8084599
Hide Technical Details
  • Tenant Id: 410addcc-0de7-4865-8028-7ac1a709acec
  • Url: https://org62d141bf.crm.dynamics.com
  • Organization Id: eb3f1c00-77c7-4d0c-8c2e-c5bcafd716ac
  • Type: Secondary
  • Unique name: org7a9feddb
  • Created on: 12/17/2019 11:44:17 PM
  • State: Enabled
  • Security Group: Not set
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Resolver I
Resolver I

Re: Can't Open Model Driven Apps

Solved!

 

All of the security groups and user were already assigned to the apps when I went into the settings.  It seems like there's a bug that forgets this.

 

To solve, you just have to open the app in the My Apps page - not within powerapps - and it fixes the issue.

 

1. Select ellipses, select share.

2. Click on the My Apps link

3. Click on the app that isn't opening

4. Save & Publish

View solution in original post

6 REPLIES 6
Highlighted
Super User II
Super User II

Re: Can't Open Model Driven Apps

@Connor55 

 

  1. Did you recently create this PowerApps Environment or Dynamics 365 Environment? If so, please wait another 30 minutes and try again.
  2. Navigate manually to https://org62d141bf.crm.dynamics.com and try to sign in. Do you get the same error?
    1. If so, the provisioning may have corrupted, so delete the environment and make a new environment.
    2. May need to make Power Platform support ticket to engage help from Microsoft on this in some cases.
    3. If you need to salvage the environment and it wasn't giving this error before and you have valuable data there, either check the Backups and restore a backup, or perhaps instead, please open a ticket with Power Platform Microsoft Support.

 

 

Finally, make sure the Model Driven App is published (not just saved, but saved and published) then retry.

Highlighted
Resolver I
Resolver I

Re: Can't Open Model Driven Apps

It's happening on multiple environments.  I actually submitted a ticket, but haven't heard from anyone in a week.

 

Microsoft's support is TERRIBLE.  This forum has been exponentially more helpful than their own tech support.

Highlighted
Super User II
Super User II

Re: Can't Open Model Driven Apps

@Connor55 

 

  1. Do you get this error even if you open a new browser tab and manually navigate to: https://org62d141bf.crm.dynamics.com/ ?
  2. Has https://org62d141bf.crm.dynamics.com/ (org id eb3f1c00-77c7-4d0c-8c2e-c5bcafd716ac) ever NOT thrown an error, or is this the first time it threw the error?
    1. About how long ago was this org last working properly, if ever?
  3.  When was tenant created (approx) of id 410addcc-0de7-4865-8028-7ac1a709acec
    1.  Or alternatively - was this tenant created within the last 7 days?
  4. When was organization (environment/instance) created (approx) of id eb3f1c00-77c7-4d0c-8c2e-c5bcafd716ac
    1. Or alternatively - was this org (env) created within the last 7 days?
  5. "multiple environments" - in tenant 410addcc-0de7-4865-8028-7ac1a709acec or across more than one tenant?
    1. Are there any environments in tenant 410addcc-0de7-4865-8028-7ac1a709acec that work at all or do they all give this error when manually navigating to the URL homepage?
Highlighted
Super User II
Super User II

Re: Can't Open Model Driven Apps

@Connor55 

 

If all else fails, try this:

 

  1. Clear cache and cookies and try again
  2. Try a completely different browser and try again
  3. Try another machine or different device (if you can) from different network (different ISP if possible) - such as from your phone on a mobile browser while connected to LTE for internet rather than Wifi - and try again and see if this helps
  4. Try checking the permissions - and try from an Office 365 Global Admin (though you may already be one)
  5. Try from a different Global Admin user (create one, if you can - and if you have enough license seats - or temporarily give a user Global Admin just to test then revoke it quickly)
  6. Try again from the user that is the original owner of the Office 365 Subscription and/or the owner of the underlying Azure tenant.
  7. Try to back up the environment and see if this helps for some reason.
  8. Try to back up the environment then recover to that backup and see if for some reason this helps.
  9. Try to create a new environment on same tenant then shortly after, delete the environment and see if this changes something on the problem environment(s)
    1. Before deleting, see if you get that error - you may get it if the environment has just been created - see if the error ever goes away after a short while like 5-10 minutes, or sometimes 30 minutes or more - or if it does not ever go away even on new environment, make a note of this

If none of this works, you may really need to try and get in touch with someone from Power Platform support - if it did not work, try again or update the ticket saying you did not get a response and would like a response soon. 

Highlighted
Super User II
Super User II

Re: Can't Open Model Driven Apps

@Connor55 

 

And also, try checking into this:

 

  1. Navigate to https://admin.powerapps.com
  2. Select your environment, especially the one(s) with issues.
  3. Does it say there's a CDS database provisioned? If so, is the version 9.1.0.10968 or later?
    1. Are you prompted to upgrade?
  4. Also, try going to Security tab (see SecTab.png screenshot)
  5. Then, Click "Assign security roles" - it should open in a new browser tab
    1. Do you still get the same error or do you see a list of users?
    2. Are there any users missing from this list compared to your Office 365 full list of users?
  6. Now, on the page that you clicked "Assign security roles" from (see SecTab.png screenshot)
    1. Try to add a user - preferably one that is missing from #5 subitem 2 above. If not, try adding any user.
    2. If it took the submission you'll get a green message (see SecTabSubmitted.png screenshot)
      1. In our experience, when we actually use this for its intended purpose which is to make users missing from the CDS users list but present on the tenant, to appear in CDS as well, it actually takes only a few seconds rather than a few minutes to do this, though you can wait a few minutes just in case.
  7. Does this resolve the error?

 

 

 
 
Highlighted
Resolver I
Resolver I

Re: Can't Open Model Driven Apps

Solved!

 

All of the security groups and user were already assigned to the apps when I went into the settings.  It seems like there's a bug that forgets this.

 

To solve, you just have to open the app in the My Apps page - not within powerapps - and it fixes the issue.

 

1. Select ellipses, select share.

2. Click on the My Apps link

3. Click on the app that isn't opening

4. Save & Publish

View solution in original post

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (6,190)