cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
jbarkerag
Advocate II
Advocate II

Can't Open SharePoint Online List Attachments from Gallery

I am building a PowerApp that allows users to see the status of a request submitted to a SharePoint Online site. In addition to viewing and editing the list item, I want them to be able to open any attachments that were submitted along with the request. I created a gallery that displays the file name and an icon image.

 

The display of the gallery works really well, however when I try to open up the link to the attachment, I get a server error. I am using Launch(ThisItem.AbsoluteUri), and it seems to be populating everything properly. But when I go to that address, I get the 404 error shown in the attached image.

 

Is there a different method for opening attachments from a SharePoint list item that I should be using? Or is this some sort of configuration issue in my SharePoint site/list?

 

 

 

Attachment Gallery.PNG

 

 

Launch Formula.PNG

 

 

Server Error Message.png

1 ACCEPTED SOLUTION

Accepted Solutions
RezaDorrani
Dual Super User II
Dual Super User II

@jbarkerag 

 

Issue is with special character # in your file name

 

Try 

Launch(Substitute(ThisItem.AbsoluteUri,"#","%23"))

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

4 REPLIES 4
RezaDorrani
Dual Super User II
Dual Super User II

@jbarkerag 

 

Issue is with special character # in your file name

 

Try 

Launch(Substitute(ThisItem.AbsoluteUri,"#","%23"))

 

--------------------------------------------------------------------------------
If this post helps answer your question, please click on “Accept as Solution” to help other members find it more quickly. If you thought this post was helpful, please give it a Thumbs Up.

View solution in original post

@RezaDorrani,

 

Thank you! That was it. I wasn't able to catch that because all of the test file names had the same character in them.

 

Should this be considered a bug for the PowerApps team to fix? All of the other characters were replaced properly in the URL string, but not #.

Hi @jbarkerag 

 

Surely a bug to fix.

I will report it.

 

Regards,

Reza

Dear, Reza!

 

          i created a Canvas App to collect vaccine info with vaccine certificates based on SharePoint list on OneDrive.

Unfortunately i cant create Power Automate Flows or i dont even see attachments!!!

Is any workaround this? may be to copy this list to SharePoint site?!

 

Thank you so much for your prompt response, Sally

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (1,198)