cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
JimmyS
Level 8

Can't create a new app - Error

Pricing_Error.jpg

 

Brand new app created in PowerAPps for Windows. No changes. Created it from my Sharepoint Pricing table. Five fields; Group, Item, ListPrice, MinFinance, MinCash.  About 100 records. No data will display. But table appears to be fine. Hovering over the formula brings up the explanation at top. I have reproduced this nearly a dozen times with different tables on both the Windows and web version of PowerApps. Can't get past square one. The app I created on Friday night with the same tables and same credentials worked fine, until today. Please, what am I doing wrong. This is driving me nuts.

 

UPDATE: Sorry if I offended anyone and did the wrong thing. I'm new to this forum. Only downloaded Power Apps on 4/21/17, although I have been subscribed to Sharepoint Online for a year. Everything was going great till yesterday afternoon when I started getting the above error message for any PowerApps app I tried to create, or existing app that I tried to save. All the apps have been created via the Sharepoint template. My Sharepoint list are being blocked by the error. I can still access my Sharepoint lists just fine via desktop apps created in Access. I am stuck now, not being able to get past square one. ANy help would be appreciated. PowerApps has great potential for our organization. I would love to start using it today. Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
JimmyS
Level 8

Re: Can't create a new app - Error

I reached out to Microsoft in the Office 365 Forums, but they said nothing regarding Sharepoint had changed in the recent update (4/24/17). They said the new features announced for Sharepoint Online were not rolling out till May. I still think some placeholders were added during the update though. As soon as I saved my first PowerApp on Monday afternoon, 4/24/17, I got errors on my first gallery screen that couldn't resolve. PowerApps was looking for a field named Title, which did not exist in my Sharepoint list. I noticed that Sharepoint did add a field, SharePointTitle(Title), but PowerApps could not resolve that.

I tried creating new Sharepoint Lists and they all failed with the same error. Looking for the field Title. In Access, I tried adding the field, Title, to my SharePoint List. But as that field name is reserved, or hidden, Access would not let me add it. Finally in frustration, on Wednesday, 4/26/17, I exported one of my lists from Access (the list was already linked to SharePoint) to SharePoint. Then, a few minutes later I imported the same list back into Access, without making any changes. The list got a _1 extension added to the back of it make it a unique name. When I opened the list, I noticed a new field, Title, had been inserted. I tried creating a PowerApp with this new SharePoint list and it worked, no errors or issues. I then repeated the same steps for the table/list I had used to create my first PowerApp. Worked perfectly. There are now two fields on my field list, SharePointTitle(Title) and Title. Still have no idea what the field is for, but as long as PowerApps is happy, I'm happy.

I created a new SharePoint list on Friday 4/28/17 and it automatically added the Title field, without having to inport/export. Worked fine to create my second PowerApp. All of my old SharePoint Lists don't have the Title field inserted though. I would need to import/export, or delete and recreate to get that field inserted. For now, my problem is solved. Hope it can help any others who stumble across this.

View solution in original post

4 REPLIES 4
Community Support Team
Community Support Team

Re: Can't create a new app - Error

Hi JimmyS,

 

Thanks for feedback.

 

I am not clear with your data source. How is your Pricing table created?


If convenience, could you show me a screenshot of your list configuration?


I test this issue with a simple custom SharePoint list, seems that there is no error when saving and editing the app.


I am trying to reproduce this issue on my side. Please help collect more information to reproduce this issue.


Best regards,
Mabel Mao

Community Support Team _ Mabel Mao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
JimmyS
Level 8

Re: Can't create a new app - Error

Thank you for the reply. All of my SharePoint lists are created using Access. I store data in the Cloud and build front ends for Windows PC to use with Access Runtime. Now I would like to be able to access/edit that data with mobile devices using PowerApps. I'm simply bringing over a single SharePoint list from my database and using it to create a simple app with a small handful of fields.

 

Note that I am having this same problem with all my databases and Sharepoint lists. I have tried several list from two different databases. Same result. The only thing that did work was exporting a SharePoint list to Excel and then linking the static data to PowerApps. The fields showed data fine and no errors on app creation. This problem has to do with linked Sharepoint lists.

 

This field in question, Title, appears in my field list, SharePointTitle (Title), but I don't know what it's for. It is not visible in my Access SharePoint list, or on SharePoint Online. As you don't appear to have the problem, I am wondering if that has to do with my subscription. I am paying for two Sharepoint licenses ($5/each per month), not full Office 365 Business Licenses. Is it possibly that I need PowerApps licenses to go with that. Everything worked fine when I logged in the first time on Friday and stopped on Monday afternoon. I can still see my SharePoint lists, but no data. Would Microsoft do that to tease me into buying the licenses? I didn't want to sign up for something I didn't need. But now it seems that may be part of the issue. I can still connect to Sharepoint Cloud data via my local desktop tront ends. No issue. Just can't get data to appear in PowerApps.

 

UPDATE: Just added Office 365 Essentials to my primary account, so I shouldn't have any issues with creating Power Apps (although I was able to last Saturday). Not sure how long it takes everything to propogate though. I had an .onmicrosoft.com account, but has no Exchange email active, so I couldn't receive anything. My Exchange account is currently being setup. Once that's done, I may try creating an app and see what happens. Fingers crossed.

 

PowerApp2.jpgPowerApp3.jpgPowerApp1.jpg

JimmyS
Level 8

Re: Can't create a new app - Error

Ok, I can't give up on this. I made an interesting discovery. I created a new table in my Access database called A2016Table and created a PowerApps form based on it. Note the same error and the SharePointTitle (Title) field in the list of available fields. Still can't see data. I then imported that table directly into SharePoint Online, creating table A2016Table_1. When I created a PowerApp based on this table, the data is visible, no errors on launch. And instead of seeing SharePointTitle (Title) in the fields list, I only see Title. This is what is causing my problem. It's a hidden field, so I can't see it anywhere. Actually, I saw it for a few seconds the first time I opened the table in SharePoint online. Now, after numerous tries, it's no longer visible. Wonder if changes are being made in the background.

 

With the table, A2016Table_1, I created, I have no idea how I could share that with anything other then web apps (fail, much too slow) or PowerApps. Don't think I can link to a local front end, as I can now do. Still confused, but progress.

 

UPDATE: So I tried something with my table with real data, TicketTable, located in my Access database, and synced with SharePoint Online. I exported the table to SharePoint. Then I imported the table back to my Access database, without making any changes. Renamed the tables, so the new one was TicketTable and the original was TicketTable_ORIG. TicketTable came back with a field labeled, Title. Created a new PowerApp and ALL my data is showing, no errors on creation. It works!  Still have a bit more tweaking to do. No idea why this is happening. But exporting/importing the table seems to work, for now.

 

 

A2016.jpgA2016-1-List.jpg

 

 

JimmyS
Level 8

Re: Can't create a new app - Error

I reached out to Microsoft in the Office 365 Forums, but they said nothing regarding Sharepoint had changed in the recent update (4/24/17). They said the new features announced for Sharepoint Online were not rolling out till May. I still think some placeholders were added during the update though. As soon as I saved my first PowerApp on Monday afternoon, 4/24/17, I got errors on my first gallery screen that couldn't resolve. PowerApps was looking for a field named Title, which did not exist in my Sharepoint list. I noticed that Sharepoint did add a field, SharePointTitle(Title), but PowerApps could not resolve that.

I tried creating new Sharepoint Lists and they all failed with the same error. Looking for the field Title. In Access, I tried adding the field, Title, to my SharePoint List. But as that field name is reserved, or hidden, Access would not let me add it. Finally in frustration, on Wednesday, 4/26/17, I exported one of my lists from Access (the list was already linked to SharePoint) to SharePoint. Then, a few minutes later I imported the same list back into Access, without making any changes. The list got a _1 extension added to the back of it make it a unique name. When I opened the list, I noticed a new field, Title, had been inserted. I tried creating a PowerApp with this new SharePoint list and it worked, no errors or issues. I then repeated the same steps for the table/list I had used to create my first PowerApp. Worked perfectly. There are now two fields on my field list, SharePointTitle(Title) and Title. Still have no idea what the field is for, but as long as PowerApps is happy, I'm happy.

I created a new SharePoint list on Friday 4/28/17 and it automatically added the Title field, without having to inport/export. Worked fine to create my second PowerApp. All of my old SharePoint Lists don't have the Title field inserted though. I would need to import/export, or delete and recreate to get that field inserted. For now, my problem is solved. Hope it can help any others who stumble across this.

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,629)