cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

Can't edit fields (line entry)

Hello,

When I click on the New button, the fields are just a line. I can't write in a text box, or select an item in a dropdown list. But I can interact with button or calendar. He seems more a visual bug.

Capture.PNG

How I can fix it ?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Community Support
Community Support

Hi @Anonymous ,

Which data source does your Edit form connect to?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider set the DefaultMode property of the Edit form to following:

FormMode.Edit

set the OnSelect proeprty of the "New" button to following:

NewForm(EditForm1);
Navigate(EditScreen)

Please consider take a try to re-generate a new app based on your data source, then check if the issue is solved.

 

If the issue still exists, please consier submit an assisted support ticket through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regads,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

5 REPLIES 5
Highlighted
Advocate III
Advocate III

Sorry to ask the obvious, but is your form's default mode set to New? Also, are the fields actual fields from the bound data source and not labels?

Highlighted
Anonymous
Not applicable

@SanAndresMan1 > Yes my form is on new mode by default

Capture.PNG

And the fields are actually fields from the bound data source.

Highlighted
Anonymous
Not applicable

Hi @Anonymous 

 

Can you check the displaymode of the Card if it is changed to View.

 

Thanks.

Highlighted
Community Support
Community Support

Hi @Anonymous ,

Which data source does your Edit form connect to?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

 

Please consider set the DefaultMode property of the Edit form to following:

FormMode.Edit

set the OnSelect proeprty of the "New" button to following:

NewForm(EditForm1);
Navigate(EditScreen)

Please consider take a try to re-generate a new app based on your data source, then check if the issue is solved.

 

If the issue still exists, please consier submit an assisted support ticket through the following link:

https://powerapps.microsoft.com/en-us/support/pro

 

Best regads,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
Anonymous
Not applicable

@v-xida-msft > I changed the DefaultMode to Edit and he seems to work. Thanks !

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,683)