cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper IV
Helper IV

Can't get SubmitForm then Navigate to work properly

I've got a form with a submission button with the function:

 

SubmitForm(EditForm1);Navigate(Finish, ScreenTransition.None)

 

It should submit the form then send the user to the "thanks for submitting your request" screen. Instead it sends them to the finish screen for half a second then sends them back to the blank form. 

 

How do I get it to stay on the finish screen instead of sending them back to the form?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User
Super User

Re: Can't get SubmitForm then Navigate to work properly

Put your navigate in the On Success Property of the EditForm.  In the example below where I have Back() which returns to the calling page when the edit is complete, put your Navigate(Finish, ScreenTransition.None)

OS1.png

View solution in original post

1 REPLY 1
Highlighted
Super User
Super User

Re: Can't get SubmitForm then Navigate to work properly

Put your navigate in the On Success Property of the EditForm.  In the example below where I have Back() which returns to the calling page when the edit is complete, put your Navigate(Finish, ScreenTransition.None)

OS1.png

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,734)