cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate I
Advocate I

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

My app is already complete, I had to make a modification to one part of it which broke the attachments control when I saved it. If you used the default version (clicking edit on the PowerApps app list) it saves it using version 3.18114.25 right now.

2018-12-20 12_34_14-Microsoft PowerApps.png

The way I got it to save using the old version is by opening the app from the older IDE. (ie. use the link to the old version >  Open PowerApps app > make your changes > save). 

2018-12-20 12_32_20-App - PowerApps.png

 

Highlighted
Power Apps
Power Apps

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

We are now trying to get this fix out within the next couple of days.

I will update this thread in that timeframe (by Monday).

Highlighted
Power Apps
Power Apps

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

This is fixed now.

Thank you all for reporting it, and for bearing with the workaround until now.

View solution in original post

Highlighted
Advocate I
Advocate I

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Thankyou for the prompt resolution to this issue. I can confirm that the file name is now available in the attachment control.

Highlighted
Regular Visitor

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi,

in an powerapp environment of one of my customer with version 3.18122.23 I have this problem. How can I have the Fix ?

 

Thanks

Highlighted
Power Apps
Power Apps

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Version 3.18122.23 is newer and hence no longer has the bug.  I suspect the app just needs to be re-saved and re-published.

To see which version the app is on:

  1. go to https://web.powerapps.com/
  2. click Apps
  3. find your app in the list, and click "..." then "Details"
  4. click on the "Versions" tab
  5. Take a look at the "PowerApps release" number of the row that has Published "Live"

I would guess that it is older.


To fix that, open the app for editing, make any change, and save the app.  Then publish that version.

Highlighted
Regular Visitor

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi,

I confirm you that in previous version of apps I haven't the problem.

The problem start, in this environment, since this version 3.18122.23.

I edited the previous version and after saving version become 3.18122.23 and attachment control doesn't work (I don't see name of file).

If I come back to previous version, work fine (Name of file appear correctly)

Highlighted
Power Apps
Power Apps

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi Friz;

I don't understand why you are still running into this problem.

Can you try to reproduce it in a new app?
Here are the steps:

  1. Go to https://create.powerapps.com/studio/#
    (note that it's by now on version 3.18124.26, which you can see when you click on Account on the left)
  2. New -> Start with your data -> SharePoint, connect to any SharePoint list you have access to
  3. Go to EditScreen1
    (note that EditForm1 should have Attachments field on by default; If it doesn't you can enable it in form's Fields -> Edit fields in the right pane)
  4. In EditForm1's Attachments_DataCard1, note the name of the Attachments control.
    (for me, it's DataCardValue3, I'll use that below)
  5. Put a couple of Label controls on EditScreen1.  Set their Text properties to be:
    First(DataCardValue3.Attachments).Name
    Last(DataCardValue3.Attachments).Name

The labels should be populated accordingly if there are any files attached, and if there are not, they should be updating as you use the app and attach / remove files.

Does that work for you?

Highlighted
Regular Visitor

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Hi Jovan,

in datacard the control attachment work fine in this version.

I have the problem with this control if I use it inside a blank screen; in previous version work fine.

 

I attach a file with an example.

Highlighted
Power Apps
Power Apps

Re: Can't return Attachment Control Name field... it work last week, now it just returns nothing.

Friz, can you contact support / send in your .msapp + the scenario of how you are using the control.  It's possible that you are using it in some way that we didn't anticipate, but that we could get re-enabled once we know the parameters.

Helpful resources

Announcements
August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,419)