cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
TBattles-1
Frequent Visitor

Can't update component library

I'm getting an error when trying to update components from a component library in a canvas happen.

 

Any solution for this?

TBattles-1_0-1599606043980.png

 

10 REPLIES 10
rimatos
Community Support
Community Support

Hi @TBattles-1 ,

 

What action are you doing to update the component on your end? I'm only able to see in the screenshot that you have an error in opening a certain file could you elaborate a little bit further on this?

 

Regards,

Ricardo

I made updates to my component library. I then switched back to my canvas app to update those components. So when it said you have updates from your component library I hit "Review" which then allowed me to hit "Update". But after hitting "Update" is when I get the error. 

It could be related with some alteration you performed on the Component. Did you remove any functionality from the component that was being used in the PowerApp at the moment?

I don't believe I removed any functionality.

 

I tried restoring an old version of the Component Library as well as the canvas app with no luck. 

 

I didn't have any issues until PowerApps version 3.20083.24.

In that case I would suggest you to raise a support ticket to Microsoft Support through https://admin.powerplatform.microsoft.com/support so this behavior can be investigated in more depth on our end.

 

Regards,

Ricardo

I am having the same issue attempting to update components in all my PowerApps as well. This issue is very recent for me as well. I suspect it has something to do with changes to the recent Power Apps version.

 

@TBattles-1, could you keep us posted on a resolution to this issue if you find one?

I finally found a solution to this yesterday. 

 

What I had to do was remove all my data sources/connections from my powerapp and then it let me update my components. I was then able to add the data sources/connections back to my PowerApp.

 

It's kind of a pain to remove and add back all the data sources, but it works. I suspect this was caused by a recent PowerApps update.

@TBattles-1, thanks for the info. Do you know if removing a Data Source breaks all the references to it? Were you able to remove and add them back without much re-writing? I shudder to think about doing this to some of our larger apps.

Removing the data source does break all references to it, but as soon as you add them back the errors should go away. I did not have to fix any of my references. 

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,941)