cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ASDemo
Advocate I
Advocate I

Can't update or create a custom connector

Hey there,

 

Since yesterday I'm not able to either create or update a custom connector. The error message is the following:

 

User with object id '063f8669-fdab-4701-a32a-0561323876e3' and scopes 'Approvals.Manage.All, Flows.Manage.All, Flows.Read.All' does not have permission to call route 'POST/PROVIDERS/MICROSOFT.POWERAPPS/APIS/'

 

I tried to do so on an other Microsoft account of my even on a other computer. Still no success.

34 REPLIES 34
Bhanu
New Member

I am also getting similar error from todays morning, unable to update existing as well as create new custom connector

 

I am getting

 

User with object id '9b7452fd-9f7e-4825-bdac-93a56e9dc75f' and scopes 'Approvals.Manage.All, Flows.Manage.All, Flows.Read.All' does not have permission to call route 'POST/PROVIDERS/MICROSOFT.POWERAPPS/APIS'.

 

Any one have resolution for this

ASDemo
Advocate I
Advocate I

Has anyone tried using different accounts as well?

 

Suji
Regular Visitor

I am also getting the same error. any update on this?

Anonymous
Not applicable

Hi All,

Getting the same error, any updates ?

 

Thanks in Advance.

AcaSPAd
Regular Visitor

Same issue here.

notj
Post Prodigy
Post Prodigy

Same issue!

notj
Post Prodigy
Post Prodigy

@EvanChakiMSFT  You were the go-to person for the same error on a different issue, in this thread: https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/Sign-in-Issues-Sharepoint-list-form...

Can you assist us with the similar issue we're having?

rvoreaux
Frequent Visitor

Hi there,

 

This is maybe not the same issue but there is some informations.

 

A colleague of mine cannot create a custom connector  since this morning (Timezone Paris, France) and had this error message : "Cannot read property 'InnerException' of undefined".

Apparently, when he's using a Virtual Machine based in US the creation/update is working fine and when he's using a local machine based in Europe, he's getting the issue.

 

On my side with the same OpenAPI file and a local machine based in Europe, I cannot reproduce the issue, all is working fine.

 

I hope those few informations will help you to find a solution

I don't believe that is related to this issue. 

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (942)