cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ASDemo
Advocate I
Advocate I

Can't update or create a custom connector

Hey there,

 

Since yesterday I'm not able to either create or update a custom connector. The error message is the following:

 

User with object id '063f8669-fdab-4701-a32a-0561323876e3' and scopes 'Approvals.Manage.All, Flows.Manage.All, Flows.Read.All' does not have permission to call route 'POST/PROVIDERS/MICROSOFT.POWERAPPS/APIS/'

 

I tried to do so on an other Microsoft account of my even on a other computer. Still no success.

34 REPLIES 34
Bhanu
New Member

I am also getting similar error from todays morning, unable to update existing as well as create new custom connector

 

I am getting

 

User with object id '9b7452fd-9f7e-4825-bdac-93a56e9dc75f' and scopes 'Approvals.Manage.All, Flows.Manage.All, Flows.Read.All' does not have permission to call route 'POST/PROVIDERS/MICROSOFT.POWERAPPS/APIS'.

 

Any one have resolution for this

ASDemo
Advocate I
Advocate I

Has anyone tried using different accounts as well?

 

Suji
Regular Visitor

I am also getting the same error. any update on this?

ShaileeShah
Frequent Visitor

Hi All,

Getting the same error, any updates ?

 

Thanks in Advance.

AcaSPAd
Regular Visitor

Same issue here.

notj
Post Prodigy
Post Prodigy

Same issue!

notj
Post Prodigy
Post Prodigy

@EvanChakiMSFT  You were the go-to person for the same error on a different issue, in this thread: https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/Sign-in-Issues-Sharepoint-list-form...

Can you assist us with the similar issue we're having?

rvoreaux
Frequent Visitor

Hi there,

 

This is maybe not the same issue but there is some informations.

 

A colleague of mine cannot create a custom connector  since this morning (Timezone Paris, France) and had this error message : "Cannot read property 'InnerException' of undefined".

Apparently, when he's using a Virtual Machine based in US the creation/update is working fine and when he's using a local machine based in Europe, he's getting the issue.

 

On my side with the same OpenAPI file and a local machine based in Europe, I cannot reproduce the issue, all is working fine.

 

I hope those few informations will help you to find a solution

I don't believe that is related to this issue. 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (54,342)