cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ASDemo
Advocate I
Advocate I

Can't update or create a custom connector

Hey there,

 

Since yesterday I'm not able to either create or update a custom connector. The error message is the following:

 

User with object id '063f8669-fdab-4701-a32a-0561323876e3' and scopes 'Approvals.Manage.All, Flows.Manage.All, Flows.Read.All' does not have permission to call route 'POST/PROVIDERS/MICROSOFT.POWERAPPS/APIS/'

 

I tried to do so on an other Microsoft account of my even on a other computer. Still no success.

34 REPLIES 34

It works in Canada at https://emea.flow.microsoft.com/

Received below message from Microsoft and it is working in PowerAutomate.

 

"As we have reported this issue to our Product Team earlier this week, they have provided a workaround for it is to create/update custom connectors using the Power Automate custom connectors experience.  As they working on it a  fix is being deployed as soon as possible to fix the PowerApps portal."

It looks like it is fixed in PowerApps now. I can edit and save.

 

Australia region

🙂

IgorAntarovDev
Regular Visitor

I have another issue with creating\updating Custom Connectors.

 

When I'm setting everything(Client ID, Client Secret, Resource URL) on the Security page and hit Create Connector, it tells me "Connector successfully created", reloads the form, and then it's empty again.  So I can't get Redirect URL and use the connector. 

 

I've tried it on different accounts with different tenants. 

I'm going trough this manual step by step with no luck: https://docs.microsoft.com/en-au/graph/tutorials/flow?tutorial-step=2

 

Can anyone please check - if it works at all? 

Is there another way to check if the Redirect URL is created? 

 

I'm attaching the screenshot that shows how it looks after 'Create connector' is pressed.

 

Connector Error 2020-05-08 142347.PNG

Any info on that? Could anyone try it if it works?
Should I start a separate thread for visibility, since it seems to be a different issue (with the same outcome)?

I can't create a custom connector at all. Because of that, I can't make MS Planner automation since it's native connector is strangely limited and not allowing updates of simple things like BicketID and checklists. So Power Automate & MS Planner leads to a dead-end in any way I'm trying to go.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

PA Community Call

Power Apps Community Call

Next call is happening on April 21st at 8a PST.

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (27,137)