cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
oruganti_osr
Frequent Visitor

Can we do Form Post from Power App

Hello,

      We have SSO url where we need to do a Form POST from Power App. Is there a way to do it?

Thanks

Sri

9 REPLIES 9
yashag2255
Dual Super User II
Dual Super User II

Hi @oruganti_osr 

 

If you wish to make a call directly through powerapps, you can create a custom connector. Please refer for more details: https://docs.microsoft.com/en-us/connectors/custom-connectors/define-blank
 
Once the connector is created, test it and add a connection to the app and trigger the request.
 
Hope this Helps!
 
If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Thank you for your prompt response. We will try and let you know.

Hey @oruganti_osr 

 

How are you progressing with this? Were you able to make this work? If not, please share more details so that we may assist you better.
 
Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hey Yash,

 

   Thanks for asking. We did not implement the solution yet. Seems like our servers are not open outside hence we are not able to POST it from cloud. Once that is resoved we may Test your solution. It may be tommorrow. I will update the status on this solution if it resolves the issue.  

 

Thank you for your help,

Srinivas

 Hey Yash,

 

  I am getting following error when I Post to url from custom connector test. 

"error": {
"code": 500,
"message": "Expression value is invalid. The template field is required.",

"source": "*****",
"path": "choose[2]\\when[1]",
"clientRequestId": "****"

}

 

do you have any idea why it is doing?

I am basically posting to URL with no authentication by sending raw body data that includes key and id. When we post, it log us to new url or redirect to another url.

It is working fine in postman and getting the correct response but not from power app.

 

Thanks

Srinivas

 

 

 

Hi @oruganti_osr 

 

Can you please share more details about the definition of the request that you have created? Based on the information shared by you, since there is no authentication required, I am guessing the issue might be with creating the definition of the request. If you can share more details about the POST request that you are trying to create, we might be able to help you better.
 
Note: Also, please try to refresh the page once, there might be a session timeout on the Test page which might also fail this request.

 

Hope this Helps!

 

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Hi,

 

   My post request suppose to look like the form post. 

When we do post from postman it returns the response.

My post just consists of URL : https://xxxx/yyy and body contains a SSO encrypted key and Id value. so my body looks like 

Key=zzzzz&Id=xxxx.

If you need any more information please let me know.

 

Thanks

Srinivas

 

 

Hi @oruganti_osr 

 

Can you try to export the Postman action and import it in the custom connector? Please export the Postman collection as v1. Once the connector is setup successfully then you can test it out if the issue still occurs.
 
Hope this Helps!
 
If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

I did export the postman collection as V1 but still got the same issue. 

 

Thanks

Srinivas

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

May UG Leader Call Carousel 768x460.png

June User Group Leader Call

Join us on June 28 for our monthly User Group leader call!

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Users online (3,203)