cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Burner1
Frequent Visitor

Cannot Clear Attachments in PowerApps

Hi,

 

I have created an app which has the possibility to add an attachment, and therefore is connected to a SharePoint list.

When I'm done creating an item in the SharePoint list with PowerApps and have added an attachment, I want to create a second item. But when I get to the screen where to add an attachment, the attachment from the previous added item is still visible.

This looks like the same problem as multiple users have described here and for those users there isn't a solution yet. Only for the poster of the item.

 

I have tried to use this:

ResetForm(EditForm1);NewForm(EditForm1);Navigate(EditScreen1,ScreenTransition.Fade)

All the fields are being resetted, except the attachment field.

 

If I remove the attachment with the "X" when I add the second item, and click on a button which have only ResetForm and NewForm as onSelect, the attachment will return. So, apparently the attachment wasn't really removed by clicking the X, otherwise it would not return right?

 

Any help would be appreciated on this strange matter.

 

 

43 REPLIES 43
freddiejoseph1
Helper IV
Helper IV

Does anyone have a fix for this?

 

I am having a similar issue where when I add or remove an attachment in a SharePoint list using SubmitForm, the attachment control/card in the form does not update.

 

E.g. I remove an attachment, click the submitform button, it gets removed from my sharepoint list, but the attachment still shows in the attachment datacard in my form.

 

Thanks,

 

Freddie

DanielRK
Super User
Super User

Hi,

 

I've got the same problem. Also have attachment field that doesn't reset after submitting an item and carries into the next submission.

 

Is it still not resolved?

 

Regards,

 

Daniel

LynetteJH
Advocate I
Advocate I

Same issue here of attachment on the first item is showing up by default on the new form for subsequent items.  All other fields are reset properly.  How is this not fixed since 2018??  Oddly, this has not been an issue for us until now, so not sure how we've not seen it previously.  But I've recreated it with a new list where I have made no changes to the default list, and no changes to the Power Apps customized form - just the default Title field and Attachments control showing and published to SharePoint.  Enter multiple items and it happens every time.  Typically, the second entry does not have a default attachment, but it starts using the first attachment on the third entry and every entry after that.  If I manually reset the list before clicking the New link, then the attachments field is blank.  I've been researching this for two days and I've tried every solution of using Reset and ResetForm I've found and nothing has worked.  Clearing the attachments on a new form should be out of the box behavior!

Hi @LynetteJH ,

 

Thanks for taking the time to reply. 

 

I couldn't agree with you more- It's a PowerApps/Sharepoint bug and should definitely work out the box.

 

I also have not found a solution to this yet.

 

I'll write back if I do find something.

 

Good luck and thanks again.

 

Regards,

 

Daniel

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Top Solution Authors
Top Kudoed Authors
Users online (2,226)