cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
GoodPanos
Frequent Visitor

Cannot Save Form After Validation Error

OOTB every time I customize with PowerPapps a SharePoint List that has any required fields, the following happens.

 

When a new item is created and I don't fill the required fields, the form spits out error messages that the required fields need to be filled.  So far so good.  Once I fill out the required fields and the errors clear, I can no longer save (submit) the form by clicking on the default save button that's at the very top.  Clicking on it does nothing.  And the end I have to cancel and start all over again.

 

I've done a few things by adding Refresh(SharePoint List) before saving to no avail.

 

The only work-around I have found is to add an actual button on the form and use the SubmitForm() function.  Then the form functions as expected but then I'm left with a button at the top that works half-ways.

 

Anyone come across this issue?

1 ACCEPTED SOLUTION

Accepted Solutions
WarrenBelz
Super User
Super User

Hi @GoodPanos ,

Strangely I posted on this same subject a short while ago for @Dave9  and suggested exactly what you have concluded. There is also some other information in there that may be useful to you.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

View solution in original post

9 REPLIES 9
WarrenBelz
Super User
Super User

Hi @GoodPanos ,

Strangely I posted on this same subject a short while ago for @Dave9  and suggested exactly what you have concluded. There is also some other information in there that may be useful to you.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

 

View solution in original post

Dave9
Frequent Visitor

This is not a solution, BUT

 

So I figured out that if you click off the form screen (which closes the form) and then click New again, it reopens what you just entered and then you can save.   

 

I very much think this is a bug but I'm not sure where to post it.  Do either of you know where bug reporting is for power apps or SharePoint? 

Thanks for sharing @Dave9 ,

I think it is a bug

Anonymous
Not applicable

I have the exact same issue and have come to the exact same conclusions. Both the click off of the form and come back and the submit button are decent work arounds but still very janky to have the OOTB save button not work in this scenario. 

 

Can we please have this bug resolved?!

Sorry, I missed the previous posting.

 

Thanks all for the suggestions.  It does look like a bug and if anyone knows where these should be posted, please advise.  

@Dave9Thanks so much for this workaround.  I've had forms working beautifully that now do not work correctly if I miss filling out a required field.  But, correcting the item, clicking off the form, clicking New and then Save works.  I have this same issue on at least two forms. 

 

There are at least three or four threads out there will all kinds of proposals regarding how to work around something such as this that should work correctly.  I'm going to go ahead and submit a Microsoft ticket to see if that gets us any help. 

 

Will keep everyone posted.  

I received this reply this morning after having submitted a ticket with Microsoft...

 

This is indeed a issue that has been posted in the forums multiple times and our developers are aware of it. They have finished the initial Fix development and are verifying the fix as they prep it for Roll out.

We have pushed to have it released as soon as possible and the current ETA sets it for in about 2 weeks(Aka the week of 04/27).

Dave9
Frequent Visitor

@CindyZ 

 

Thank you for replying back!  Glad to hear they are working on it!

FYI, I received this from Microsoft yesterday stating this issue has been resolved.  I tested on my two forms that I knew were affected and it seems to be working beautifully now.  Just wanted to pass that along! 

 

Issue: When using Custom form, if a field marked as required is missed and you save, it breaks the form.

 

Resolution: This was an issue reported by multiple customer and our developers were made aware. Once confirmed they worked on developing a fix and had it expedited to the verification and validation phase before it was added into the next quick release. Once released it has been confirmed by multiple customers(including you) that the issue is resolved and the form is not breaking.

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,155)