cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
peterhay
Level: Powered On

Cannot activate rear camera within Site Inspector PowerApp on my Google Pixel 3 XL

Hi

 

I have loaded the Site Inspector PowerApp to see how camera functionality within PowerApps works. No matter what value (0, 1, 2) I set for the "Camera" variable in the Camera control properties when I view the App on my Google Pixel XL 3 phone it always displays the front facing camera.

 

I have tested the same App on a Samsung Galaxy S7 device with the following results...

Setting of 0 displays the rear camera

Setting of 1 displays the front camera

Setting of 2 displays message "Your camera isn't set up, or you're already using it" message

 

And on the Google Pixel 3 XL device...

Setting of 0 displays the front camera

Setting of 1 displays the front camera

Setting of 2 displays the front camera

 

Please can you update so that I can display the rear camera on the Google Pixel 3 XL as well?

 

Thanks

Peter

 

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support Team
Community Support Team

Re: Cannot activate rear camera within Site Inspector PowerApp on my Google Pixel 3 XL

Hi @peterhay ,

Is the PowerApps Mobile App in your Android device the latest version?

I have made a test on my side (within my iOS device, iOS Version: 12.1.4), and don't have the issue that you mentioned.

Setting of 0 displays the rear camera

Setting of 1 displays the front camera

 

Please check if the version of PowerApps Mobile App in your Android device (Google Pixel 3 XL) is the latest version. If not, please upgrade it into the latest version, then check if the issue is solved.

In addition, the user @Iconic has faced similar issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/Google-Pixel-3-Powerapp/td-p/181278

It seems that with the Pixel 3 with 4 cameras 0, 1 and 2 are the front cameras, and 3 and 4 are the back cameras.

Please consider take a try to set the Camera property of the Camera control to following:

3  /* or 4*/

then check if the issue is solved.

 

If the issue still exists, please consider take a try to uninstall PowerApps Mobile App from your Android device, then re-install it again, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

2 REPLIES 2
Community Support Team
Community Support Team

Re: Cannot activate rear camera within Site Inspector PowerApp on my Google Pixel 3 XL

Hi @peterhay ,

Is the PowerApps Mobile App in your Android device the latest version?

I have made a test on my side (within my iOS device, iOS Version: 12.1.4), and don't have the issue that you mentioned.

Setting of 0 displays the rear camera

Setting of 1 displays the front camera

 

Please check if the version of PowerApps Mobile App in your Android device (Google Pixel 3 XL) is the latest version. If not, please upgrade it into the latest version, then check if the issue is solved.

In addition, the user @Iconic has faced similar issue with you, please check the response within the following thread:

https://powerusers.microsoft.com/t5/General-Discussion/Google-Pixel-3-Powerapp/td-p/181278

It seems that with the Pixel 3 with 4 cameras 0, 1 and 2 are the front cameras, and 3 and 4 are the back cameras.

Please consider take a try to set the Camera property of the Camera control to following:

3  /* or 4*/

then check if the issue is solved.

 

If the issue still exists, please consider take a try to uninstall PowerApps Mobile App from your Android device, then re-install it again, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Highlighted
soylaunica
Level: Powered On

Re: Cannot activate rear camera within Site Inspector PowerApp on my Google Pixel 3 XL

I also have this issue on my Pixel 3. Have you found a solution? Reinstalling doesn't work and my phone is updated.

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors
Users online (5,855)