cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Cannot play a canvas app after importing it from a managed/unmanaged solution

Hi,

 

I cannot play a canvas app after importing it from a managed/unmanaged solution. 

 

My process:

  1. create a solution in my dev environment
  2. create a canvas app inside that solution
  3. export solution as either managed or unmanged
  4. import solution into testing environment

The canvas app show up inside the solution in the new environment - but I don't have an option to play the canvas app. When I click on the canvas app it takes me from the solution screen to the "app" screen - but the canvas app is not listed in the list of apps. 

 

I have tried re-creating the connectors in the new environment, clicking 'publish all customization's' and the log file says the solution imported successfully without any issues.

Screenshot of the solution imported into the testing environment: Photo1
Screenshot of when I click on the canvas app and it taking me to the apps screen - but the imported app is not listed - Photo2

I have got this to work by exporting the canvas app directly by exporting it as a package - But I don't think this is the correct way to manage apps using a proper development life-cycle. Any help is appreciated. Thanks!

 
 
 
5 REPLIES 5
Continued Contributor
Continued Contributor

I am getting the same error. I am trying to do a managed solution, and I can see the app inside solution but once I click the app it takes me to app page where I don't see it. Were you able to figure it out?

 

Thanks!

Hi, No solution yet - I have just been using the export app direct function rather then the export solution function. I tested it with a model driven app and that works fine so its something to do with a canvas app. 

Helper V
Helper V

After importing managed solution it's taking 10 to 15 minutes for canvas app to show up.

 

Frequent Visitor

I have the same problem, but the canvas app does not show up after any period of time.  I see it in the solution, but not under "Apps".  If I click on it in the solution, it navigates to "Apps" and just shows me a list of apps that does not include the one that I am interested in.  One thing of note is that I am exporting the solution from a sandbox environment and importing it into a production environment.  

Frequent Visitor

While looking around in the admin environment, I found something interesting.  If I navigate to: https://admin.powerplatform.microsoft.com/environments/put-your-environment-guid-here/powerapps/, I find that my app is there and owned by the correct user, but not shared with anyone.  I was able to share it from that view and it is now visible in "Apps" where I wanted to see it.

Helpful resources

Announcements
secondImage

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

Top Solution Authors
Top Kudoed Authors
Users online (12,884)