cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RashiSaxena
New Member

Canvas app working in preview mode but not in published version

I am having a strange issue in one of my canvas app. I am populating a combobox datacard with a collection. The collection is getting set on start of the app. It's working all fine in the preview mode. But, when I check in the published app, its not working. I used Monitor debugging and found that collection is returning 0 rows in published mode whereas in edit/preview mode I can easily see that collection is setting correctly as required.

 

I am clueless what to check more, and how to fix it. Can anyone please guide me what next steps I can look into to fix the issue?

1 REPLY 1
v-jefferni
Microsoft
Microsoft

Hi @RashiSaxena ,

 

Do you mean that collection created in OnStart of the app not working in published app?

 

If so, you could move the collection creation formula to OnVisible of the main screen then check if it could work. Sometimes data is not ready when app's OnStart.

 

Hope this helps.

 

Best regards,

Community Support Team _ Jeffer Ni
If this post helps, then please consider Accept it as the solution to help the other members find it.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (37,170)