cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
sravyabollineni
Frequent Visitor

Change/Update data source of a Gallery control

I have a custom connector binded to a Gallery in it's data source.

I later had to edit the connector's request and response parameters after which the connector works perfectly fine.

But then, after editing the formula in the data source, it shows no data.(screenshot below)

 

sravyabollineni_2-1622063884862.png

 

Whereas in a whole new Powerapps session, data renders perfectly fine(as shown below).

 

sravyabollineni_1-1622063830636.png

 

How do I refresh the Gallery data source with the new parameters. The Items field of the gallery also renders itself uneditable at times.

I can't afford to design it from scratch, since the whole screen is already in shape. 

 

Any help much appreciated !!

1 ACCEPTED SOLUTION

Accepted Solutions
C-Papa
Super User
Super User

Hi, If the data is correct in the collection / data source have you tried simply refreshing the gallery in the onchange property of the dropdown e.g. Reset(Gallery1)

View solution in original post

2 REPLIES 2
C-Papa
Super User
Super User

Hi, If the data is correct in the collection / data source have you tried simply refreshing the gallery in the onchange property of the dropdown e.g. Reset(Gallery1)

@C-Papa 

Thanks for responding. Unhooking the data source with the gallery and adding it back all over again worked. 

Helpful resources

Announcements
PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

Microsoft Build 768x460.png

Microsoft Build is May 24-26. Have you registered yet?

Come together to explore latest innovations in code and application development—and gain insights from experts from around the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,103)