cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
WendyP
New Member

Changes in an 'Assign to' people field are not saved

Hi,

 

I have created a canvas app based on a SharePoint list that contains some fields, nothing special. One of them is a people field 'Assign to' where I need to be able to select a person from existing accounts. Works fine. 

But when I open an existing item, click Edit and change some fields, including replacing the person in the people field with another person, all changes are saved, except for the change in the people field. Still shows the first person. 

My 'Save' button simply says SubmitForm(MyForm) & Navigate(OtherForm)

What am I missing...?

 

Your help will be much appreciated! 😉

 

Wendy

1 ACCEPTED SOLUTION

Accepted Solutions

I removed the datacard and added it again, and now it works. 

 

It was behaving very strange. I was even allowing me to add 2 persons, didn't gave me an error but didn't save. Also, in SharePoint it wasn't defined as multi select, but in the Power Apps properties, the switch of multi select was on! 🤔 So I think it got corrupted at some point. 

 

But thanks a lot for your help @RandyHayes , you definitely helped me re-evaluating the multiselect thing. 😉

View solution in original post

6 REPLIES 6
RandyHayes
Super User
Super User

@WendyP 

My first question would be, is the column defined in SharePoint to allow Multiple people?  

If so, then that could be the source of the issue.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

No, not defined as multi select...

@WendyP 

Well we can check that one off the list!

 

I will assume you have created a Canvas app (as opposed to customizing the forms in SharePoint) and that you have either created that From Data or that you added your own EditForms.  (if this assumption is off, please inform)

 

So, what is the Update formula on your Assign To datacard?

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Yes, created a canvas app and I use SharePoint lists as data sources.

 

The Update formula is the default: DataCardValue11_3.SelectedItems

@WendyP 

 

And you altered nothing else???  That formula should be DataCardValue11_3.Selected !!

 

I tried to repeat the steps with a SharePoint list that has a Person column (single person) in it and created an app from Data and chose that list.  I did this just in case the was some new issue with doing so.  But, my formula was correct on the EditForm DataCard.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

I removed the datacard and added it again, and now it works. 

 

It was behaving very strange. I was even allowing me to add 2 persons, didn't gave me an error but didn't save. Also, in SharePoint it wasn't defined as multi select, but in the Power Apps properties, the switch of multi select was on! 🤔 So I think it got corrupted at some point. 

 

But thanks a lot for your help @RandyHayes , you definitely helped me re-evaluating the multiselect thing. 😉

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Super User 2 - 2022 Congratulations

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

September Events 2022

Check out all of these events

Attend in person or online, there are incredible conferences and events happening all throughout the month of September.

Users online (2,691)