cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
RvdHeijden
Post Patron
Post Patron

Changing a Column type in SP and now Powerapps wont get the new columntype

I've got (kind of) a stupid question.

 

I've mad a column in SP, a Yes/No field, and then added that in PowerApps and it worked fine. But now I need to change that Yes/No column to a choice column based on Yes, No and N/A but somehow PowerApps just keeps adding the Bolean columntype instead of the choice column

 

Ive tried deleting the column in PowerApps (couple of times) and refreshing the tabel in Powerapps but with no result.

Is there a way to refresh or something or do i need to completely delete the table and add it again because that would suck 🙂

1 ACCEPTED SOLUTION

Accepted Solutions
Pstork1
Dual Super User
Dual Super User

When you say "refreshing the table" does that mean refreshing the data source itself?  You need to use the context menu in the list of data sources to refresh the schema of the SharePoint list.

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365 and PWR EduCon in Chicago
EduCon Chicago 2022

View solution in original post

7 REPLIES 7
Pstork1
Dual Super User
Dual Super User

When you say "refreshing the table" does that mean refreshing the data source itself?  You need to use the context menu in the list of data sources to refresh the schema of the SharePoint list.

image.png



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365 and PWR EduCon in Chicago
EduCon Chicago 2022

timl
Super User
Super User

@RvdHeijden 

When you say "refreshing the tabel in Powerapps", do you mean that you selected the SharePoint list in the data panel and clicked the 'Refresh' option that's available beneath the '...'  menu? That process would normally fix this issue.

@Pstork1 that is what I mean and I've already tried that option a couple of times but the result for that column remains Bolean instead of a Choice column. 

In SP the column already changed obviously but PowerApps keeps adding the old columntype

@timl that is what I meant but it won't change the columntype

That should fix it.  If that doesn't you may have to remove the entire connection and re-add it to the app.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365 and PWR EduCon in Chicago
EduCon Chicago 2022

@Pstork1 and @timl yesterday it didn't work but when I tried the same thing this morning it did change the columntype, so I'm guessing it takes more then a little while for it to work.

 

Anyways the problem is fixed now

I suspect its the difference between changing a column and adding a column.  When adding a column there is no delay.  But it may take time for changing a column to get picked up because there is no new column, just a change in schema.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

Join me at 365 and PWR EduCon in Chicago
EduCon Chicago 2022

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Users online (2,521)