cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aprildunnam
Power Participant
Power Participant

Chatbot App

Has anyone messed with and been able to get the ChatBot App demo working.  I'm following this article: https://powerapps.microsoft.com/en-us/blog/powerappsbot/  but am having trouble getting the submit button to fetch the answer.  I've tested the chat bot in Postman and tested in my PowerApps Custom Connector and it returns my answer as expected.  The issue I'm having is when I'm setting up the button to retrive my response per the article directions "answers" doesn't come up for me as an option.  Any ideas?  I've attached a screenshot of what I'm talking about.

2 ACCEPTED SOLUTIONS

Accepted Solutions

Thanks Shane.  I saw his video, unfortunately it doesn't go into the details, it's just high level.  I was able to figure out the issue though.  I manually created my request instead of importing and that seemed to resolve the issue.  

View solution in original post

I actually did get this working to replace a client's FAQ page.  The issue was the JSON from Postman was malformed so I manually typed in the Response in my connector and it worked!

View solution in original post

4 REPLIES 4
Shanescows
Super User
Super User

I haven't tried it but I do know that Daniel did a video on similiar. https://www.youtube.com/watch?v=xk1DE0jf9LQ Might check it out and see if it helps. 

Shane - Microsoft MVP, YouTube, and PowerApps Consulting for when you are in a bind to get this fixed quickly. And finally we now have PowerApps Training

Thanks Shane.  I saw his video, unfortunately it doesn't go into the details, it's just high level.  I was able to figure out the issue though.  I manually created my request instead of importing and that seemed to resolve the issue.  

View solution in original post

mr-dang
Community Champion
Community Champion

I have not played with bots yet, but this looks like an interesting project--any luck since posting?

Microsoft Employee
@8bitclassroom

I actually did get this working to replace a client's FAQ page.  The issue was the JSON from Postman was malformed so I manually typed in the Response in my connector and it worked!

View solution in original post

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

R2 (Green) 768 x 460px.png

Microsoft Dynamics 365 & Power Platform User Professionals

DynamicsCon is a FREE, 4 half-day virtual learning experience for 11,000+ Microsoft Business Application users and professionals.

Users online (2,361)