cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
aprildunnam
Level 10

Chatbot App

Has anyone messed with and been able to get the ChatBot App demo working.  I'm following this article: https://powerapps.microsoft.com/en-us/blog/powerappsbot/  but am having trouble getting the submit button to fetch the answer.  I've tested the chat bot in Postman and tested in my PowerApps Custom Connector and it returns my answer as expected.  The issue I'm having is when I'm setting up the button to retrive my response per the article directions "answers" doesn't come up for me as an option.  Any ideas?  I've attached a screenshot of what I'm talking about.

2 ACCEPTED SOLUTIONS

Accepted Solutions
aprildunnam
Level 10

Re: Chatbot App

Thanks Shane.  I saw his video, unfortunately it doesn't go into the details, it's just high level.  I was able to figure out the issue though.  I manually created my request instead of importing and that seemed to resolve the issue.  

View solution in original post

aprildunnam
Level 10

Re: Chatbot App

I actually did get this working to replace a client's FAQ page.  The issue was the JSON from Postman was malformed so I manually typed in the Response in my connector and it worked!

View solution in original post

4 REPLIES 4
Super User
Super User

Re: Chatbot App

I haven't tried it but I do know that Daniel did a video on similiar. https://www.youtube.com/watch?v=xk1DE0jf9LQ Might check it out and see if it helps. 

Shane - Microsoft MVP, YouTube, and PowerApps Consulting for when you are in a bind to get this fixed quickly. And finally we now have PowerApps Training
aprildunnam
Level 10

Re: Chatbot App

Thanks Shane.  I saw his video, unfortunately it doesn't go into the details, it's just high level.  I was able to figure out the issue though.  I manually created my request instead of importing and that seemed to resolve the issue.  

View solution in original post

mr-dang
Level 10

Re: Chatbot App

I have not played with bots yet, but this looks like an interesting project--any luck since posting?

Microsoft Employee
@8bitclassroom
aprildunnam
Level 10

Re: Chatbot App

I actually did get this working to replace a client's FAQ page.  The issue was the JSON from Postman was malformed so I manually typed in the Response in my connector and it worked!

View solution in original post

Helpful resources

Announcements
thirdimage

Power Apps Super User Class of 2020

Check it out!

thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors
Users online (5,505)