cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Checkbox default value perform in a weird way

Greetings All,

 

I have a gallery list of checkboxes where on its default event I'm checking whether or not the checkbox value should be marked as tick or not. The app works successfully on the web, and it displays the tick mark on those checkboxes which have the data. However, when the same app is run on the mobile devices it doesn't mark the checkbox value to true. I've tested the app on a few devices, on one mobile device the checkbox value displayed tick mark and on the rest of the mobile devices it doesn't display the tick mark.

 

I'm not sure is it the issue with the power app, or with mobile OS or with my code.

Can anyone help me figure out this problem?

 

Capture.PNG

Following is the image of that one exceptional device where the checkbox value was display as true. and with another device where the checkbox value displays the true mark. Thank you

 

WhatsApp Image 2019-07-15 at 3.04.55 PM.jpegWhatsApp Image 2019-07-15 at 3.04.56 PM.jpegWhatsApp Image 2019-07-15 at 3.04.57 PM.jpeg

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Anonymous
Not applicable

Re: Checkbox default value perform in a weird way

I found the solution, the problem was with the date format. In some devices, date was stored in July 15, 2019 format while on some the date was being stored in 7/15/2019.  So, when I was filtering the data of today by string comparison it doesn't make the checkbox mark tick. 

View solution in original post

2 REPLIES 2
Highlighted
Super User
Super User

Re: Checkbox default value perform in a weird way

@Anonymous 

I would be suspect of DailyCheck.

As a test, I would put a label on the screen somewhere with the following formula:

   CountRows(DailyCheck)

 

Then try this on the different devices and see if the label count is the same on all of them or if they are different.

 

I hope this is helpful and leads to a solution.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Highlighted
Anonymous
Not applicable

Re: Checkbox default value perform in a weird way

I found the solution, the problem was with the date format. In some devices, date was stored in July 15, 2019 format while on some the date was being stored in 7/15/2019.  So, when I was filtering the data of today by string comparison it doesn't make the checkbox mark tick. 

View solution in original post

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (4,019)