cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Microsoft
Microsoft

Checkboxes checked by default return "false"

I have hit a following issue - I have created a form with a checkbox that is checked by default. When I get it's value I get "false", when I click on it to uncheck it the value stays "false" and when I click again to check it back then value displays correctly as "true". I have worked around it by puttin the "true" value into "Default" property of the checkbox on form visible, but it would be good to have the checkboxes return correct values.

1 ACCEPTED SOLUTION

Accepted Solutions

Thanks @Meneghino for the remindings.

Symptom could be reproduced when trying to re-Edit the App from my side.

When App is under running mode, the value is correctly displayed to true, while after click the Edit and load the app into Edit mode, the Label text changed to false.

I will collect this feedback from my side.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

6 REPLIES 6
Community Champion
Community Champion

Hi @PWrobel

This indeed seems like a bug.

Community Support
Community Support

Hi @PWrobel,

 

Thanks for the feedback.

Could you please explain a bit for how you managed to have the checkbox in a checked status by default?

 

Based on what I know, to change the checked status, the Default property of the CheckBox should be modified to true, and doing this would have the CheckBox.value set to true when checking its value.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks @Meneghino for the remindings.

Symptom could be reproduced when trying to re-Edit the App from my side.

When App is under running mode, the value is correctly displayed to true, while after click the Edit and load the app into Edit mode, the Label text changed to false.

I will collect this feedback from my side.

 

Regards,

Michael

 

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Hi
Is there a fix for this?
I have exactly the same issue
If the default is true (by picking up the previously patched value) powerapps checkbox.value  = false when returning to the screen even though it shows the box as ticked on screen
Unticking and ticking resolves  this, but is not a fix because if you do not do this and subsequently patch the value again it will set the saved value to ‘false’

Ended up taking screenshot of ticked and unticked checkbox
created 2 x images and applied some variables to show/hide and set value to true/false
clunky but looks the same - and it works

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (9,484)