cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Choose a gateway not showing up

Hello Community,

 

I have built a few PowerApps and had it all connected to the Data gateway just fine before. However, this morning, I noticed the connection is not working anymore with PowerApps. PowerBI is still working just fine. 

 

After reading some similar and old posts, I uninstalled the existing Data Gateway even though it was still working with PowerBI and updated/re-installed a new one (had to update .Net framework to install the Data Gateway. 

 

The PowerBI is up and running again however, I am still having the same problem with PowerApps. Please help!!! 

 

 
 
 
 
2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Choose a gateway not showing up

Hi @lliu08 ,

I've made a similar test and not met the same problem like your description.

My gateway could be chosen in the selection of gateway.

11261.PNG

 

So that should not be the problem of gateway server.

Please check these points:

1)you could only use geteway in default environment

2)please download the latest version of gateway here:

https://www.microsoft.com/en-us/download/details.aspx?id=53127

3)please try to restart your gateway and check its network status

4)make sure that you are in a good condition of neywork

Here's a doc about troubleshoot the on-premises data gateway that may help you:

https://docs.microsoft.com/en-us/data-integration/gateway/service-gateway-tshoot

What's more, the On-premises data gateway (personal mode) option can be used only with Power BI. Please make sure that you not choose this kind of gateway.

 

Best regards,

Community Support Team _ Phoebe Liu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Helper I
Helper I

Re: Choose a gateway not showing up

I do see the "Choose a Gateway" but within the drop box, my gateway isn't showing up. That is the problem. 

 

PowerBI seems to work just fine using the new gateway I installed but PowerApps isn't working. 

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Robotic Process Automation

Let's talk about the solution provided by Microsoft for Robotic Process Automation (RPA)

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

Top Solution Authors
Top Kudoed Authors
Users online (8,786)