cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kudo Kingpin
Kudo Kingpin

Cleaning up/removing unused Connections?

I have an app that I built a while ago. That app calls several Power Automate flows, and originally, most of those flows used the "Send an email" action from the Office 365 Outlook connector. We've had pushback from some of the potential users of the app over allowing the Office 365 Outlook connection. Basically, the language used to describe what the connection allows - while technically accurate - is somewhat vague and suspicious. "Why would this app need to create, edit or delete my email messages or contacts??" The app doesn't, but when you use one action from a connector, they need to allow/accept the entire connector, not JUST that action. It'd be great if there were a way for app makers to define some text that appears before that connection dialog so that they could explain what each connection is used for, but that's another gripe for another day.

 

What I writing about today is "How do I fully remove that Connector from the App?" I've updated the flows to use a different send email action (the one from the generic-looking "Mail" Connector), removed the flows from the Data Sources for the app, saved/published/closed/reopened the app, re-connected the flows where appropriate, and again saved/published/closed/reopened. However, after all that, when I go to the app's details page and look at the Connections tab, the Office 365 Outlook connector is still there. I've confirmed that NONE of the flows used with/connected to the app use it, and ensured that it was removed from those flow entirely. Still, the app says it needs that connection. Any suggestions, short of completely rebuilding the app (which isn't in scope or budget right now)?

1 ACCEPTED SOLUTION

Accepted Solutions
Super User III
Super User III

Hi @ChadVKealey ,

This may be oversimplification, but have you removed the connector in View > Data sources > click on three dots > Remove?

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

View solution in original post

3 REPLIES 3
Super User III
Super User III

Hi @ChadVKealey ,

This may be oversimplification, but have you removed the connector in View > Data sources > click on three dots > Remove?

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

View solution in original post

Actually, that's exactly what it was and I was overlooking it. Discovered that about 3 hours after posting and never went back to mark it as "solved". 

Thanks @ChadVKealey ,

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily and also closes the item.

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (35,395)